Plays out of wrong speaker

Good day—

Sorry, real beginner here (creating Picroft on Raspberry Pis as a virtual project with my kids and the grandparents). Ours work great (thanks!), but with one glitch: while we chose the 3.5 mm jack as the audio output so it would play out of the connected Logitech Z50, audio only will play out of the monitor’s speakers.

Any idea how to change it?

So far we’ve

*Unplugged the monitor (connected the micro HDMI) and spoke commands. No response came out of the Logitech Z50 speaker. When we plugged the monitor back in, we could see that Picroft had in fact heard our command.

*Tested the Logitech Z50 speaker. It worked fine both on the Raspberry Pi when booting to the OS and when connected to an iPad.

Any suggestions? Thanks!

you can go to /var/log/mycroft you have 5 files look audio. log or voice.log
the error must be in I think

Did you try to access to picroft in ssh instead of the TV
I think unplug monitor change config in mycroft

I hope that help

1 Like

You’ll probably have to set the default pulse sink to the z50’s. The audio troubleshooting documentation has more about this.

1 Like


I was able to change the default sink to 0 or 1 (other options came back with "No valid command specified). With both 0 and 1 though, the audio kept playing out of the monitor’s speakers when I ran audiotest.

I also ran audiotest under each option, unplugging the monitor as soon as I entered the command (making the Z50 the only speaker attached to the system). In neither instance though did the test play back to the speaker (I just got silence).

Any other suggestions?

Thanks again.

Hello again. Been working my way through the suggestions at

When I enter pactl list sinks short the two options that appear are

``0 alsa-output.platform-bcm2835 _audio.analog.mono
1 alsa-output.platform-bcm2835 _audio.analog.mono.2

Again, I’m a newbie, but it doesn’t look like the Z50 is even appearing as an option.

Am I right? Thanks!