Picroft setup issues

I have downloaded and installed the Picroft iso image.

I have imaged my SD card 3 different times thinking maybe I used an older version. This image is PiCroft_v0.8b.

I can’t get PiCroft to give me the pairing code or recognize voice. I am getting numerous errors about not finding directories and authorization invalid errors. I followed the step by steps directions on the site here, but I seem to be having no luck at all. Can someone help me out with these issues?

Will need a bit more information about what’s going on to be able to help. Can you share some logs of the errors? Are you running on a pi3 or something else?

Yes it is on a pi 3.

The newest one is "mycroft.configuration - Warning - Failed to fetch remote configuration: HTTPError (u’The supplied authentication is invalid’)

I also get mycroft.configuration - Debug- Configuration ‘/home/pi/.mycroft/mycroft.conf’ not found.

i can do lusb and list my speakers and my mic but no sound or voice commands can be given.

If I ssh into the device It will then use sound to the speakers giving me the pair code. But I can’t login to the web browser to enter the pair code b/c it says i’m using the wrong username and password. Which this is the only username and password I have and I can login to post to the forum so it must be right???

Also to note I am on a wired ethernet connection. I tried setting up via wireless however I can’t find the mycroft network. It was just easier to plug it in until I can get the other bugs worked out.

I feel like there is something with the image. There is a long list of directories that it can’t find.

Also on boot "The following signatures were invalid: KEYEXPIRED 1498079186 repeated multiple times.
GPG error: http://repo.mycroft.ai debian InRelease:


lib conf.c 4259 (snd_config_evalute) function snd_func_refer returned error: No such file or directory.

Hello @ssanders, can you update your Mycroft version? Do sudo apt-get update && sudo apt-get install mycroft-core, also the GPG key error can be fixed by this command sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F3B1AA8B.

Also the picroft for some reason takes a LONG time to download the skills. Go into your skills directory cd ~/skills and do an ls -al to see if you have all the default skills downloaded. Paring may not be working because the pairing skill has not yet downloaded.

To debug to see if you mic is working, first update the Mycroft package from the instructions above, then enter the Mycroft cli by typing cli on picroft or python mycroft.client.text.main cli --quiet for the other platforms. On the bottom right, you should see a sound meter going up and down, which should help you debug if your mic is being picked up by Mycroft. Note that feature is only available on more recent Mycroft packages that’s why you would need to update to see that.

Thank you. I will try that tonight.
To enter these commands I will need to enter cntrl c first correct?
That seems to be the only way to the cli I know of. Also a good way to exit from cli without having to reboot my entire unit would be very beneficial to know.

Thank you again all for the help.

Yes on the picroft, it automatically boots to the mycroft cli. You can exit that cli by ctrl + c.

sudo apt-get install Mycroft it says “E: Unable to locate package Mycroft”

i tested my microphone with test_microphone … when i say hey mycroft no response …

i am using usb mic and a analog speaker … both are working in testing … but its not listening to wake word.

I also seem to be having Mic issues with my picroft. I can see the microphone there via lusb.

I don’t mind getting another mic. I just want to be sure that I can’t use this one first.

It is a usb logitech mic.

To Note when I am entering commands through CLI everything works great. Currently I am still in a testing environment with all this, but would like to get the mic and everything confirmed working prior to moving it to its final home in my living room where I then can just ssh with it. I will likely look into getting a blue tooth mic or something smaller that will be further away from the pi itself.

Thanks again for all the help.

@suryakumaran I aplogize. It’s actually sudo apt-get install mycroft-core

@ssanders best way to check the mic if it’s works for mycroft is to just enter the cli after updating mycroft-core package

Hello. Im wondering what the username and pass for picorft is to ssh into? “Mycroft” and “mycroft1” is not working.

Hi @JustAnotherGuy,

If you’re on a recent version of Picroft, the user is pi and the password is mycroft.

Please let us know how you go,

Kind regards,

I had another version of picroft and the password was raspberry.

Did you solve your mic issue? Mine won’t work and I can’t figure it out.

Hey @darlingtom, have you seen our Picroft audio troubleshooting documentation over at: