Picroft on the 4b with accessories

Looking to set up picroft on the 4b 8gb with a Logitech c916 webcam/microphone and a generic USB sound bar (listed as “Honkyob” brand) wondering if I need to do anything special or if all should work fine with the way stuff is currently set for configuring?

Should work fine, try it and see, let us know if you have issues.

ok the main problem is the usb speakers (Logitech s120 2.0) not functioning and not being able to figure out hoe to make them do so.

can confirm the logitech c961 webcam/mic combo functions on the 4b pi croft though.

Were you able to get things working after chat discussion? Or is this still an issue?

i got my 3.5 audio connection logitech S120’s in and they dont work with it either, was given the advice to try the raspi-config and set audio to 3.5 instead of hdmi and got nada, but when i reboot, there the distinct pop of the speakers getting signal. so i have no idea.

Initially I also had sound problems with Picroft, but I succeeded when using just plain Raspbian and then installing the Mycroft repo via git (and then the normal setup). So maybe you want to try this out, if the disadvantages from not using Picroft (Mycroft doesn’t start automatically on reboot) aren’t a problem to you.
Hope I could help :+1:!

1 Like

I might give this a try should messing with the pulse audio and alsamixer settings fail. Thanks for the tip.

White flag Update. Making the attempt at downloading raspbian and git mycroft, seems like my only work around at the moment with my level of skill

Maybe I’m mentioning something basic, but thought I’d plow ahead anyway.
I initially tried Picroft on a Pi 3B+, thought there was something wrong while using the 3.5mm jack, so then tried a Pi 4 as well, same results.
I then read and read, and only saw the comment about editing
so that the file only has

“play_wav_cmdline”: “aplay %1”,
“play_mp3_cmdline”: “mpg123 %1”,

I flashed the microsd card as I switched Pi models, this file always had characters between aplay and the %1 and between mpg123 and %1 on each line.
After I removed the extra characters so that the file was as the example shows, both Pi’s work.
A restart is necessary after editing too.


messing with the coding side was not to much avail for me. but it did replace the s120’s with a logitech z50 and the power block with an actual power source and vooleee, it speaks. more research is needed to see if i can get the s120’s to function.