Picroft not working with mic array HAT

i tried picroft with an usb mic and it didn’t work so i ordered a MakerHawk ReSpeaker 4-Mic Array and it still isn’t working. I went through the setup wizard, it installed a bunch of stuff but problems started when i had to test the mic. The default mic test when setting up gets stuck while recording and so does it with

arecord -d 10 test.wav

it just says it’s starting to record and never stops and i have to ctrl+c out of it. (this seems like a major issue and probably the reason it isn’t working?)

It doesn’t show up in mic level when i go to mycroft-cli-client.

pactl info shows me that the right one is selected (i think) and it even shows up as “running”:


alsamixer looks like this, i don’t really know what to make of this:


can someone please help me with this or point in the right direction? The audio-troubleshooting site didn’t help.

You’d be right it’s a major issue. Please post the text itself and not a screen shot.

What have you tried so far? What was the result of that effort? What’s in the logs (/var/log/mycroft/*)?