Picroft Image Issue with Third-Party skills

Hello All,

I am creating a new skill (at least trying to) for my Picroft. I am not creating anything fancy, just my first skill. The skill is very simple, I say, “Hey Mycroft hand me a cookie” and my croft is just supposed to respond “here you go” or a variation of this. However, when I use either the msm install command or just git clone from my github repository and then restart my skill is not working. I say, “Hey Mycroft hand me a cookie” and Mycroft responds with, "Sorry, I don’t understand the phrase hand me a cookie.

When i look in the /var/logs/mycroft-skills.log file I see that the utterance “hand me a cookie” with the type “intent_failue”. Then it falls back to the WolframAlpha Skill which causes the response "Sorry, I don’t understand the phrase hand me a cookie.

I believe I have followed all the proper steps to create the code and install it from github, I have tried installing it using both the msm install command and the git clone command (rebooting the pi after each install before testing). Please feel free to check out the basic code for the skill https://github.com/dleweyiv/HandMeSkill

Thank you to anyone that is willing to help!


I installed mycroft on to my computer running Ubuntu, and when I installed the HandMeSkill I mentioned above it worked perfectly. I have tried re-imaging my Picroft a few times, even used multiple SD cards and multiple raspberry pis and everything is giving me the same issue I had previously (i.e. when I install any third-party skills they do not run properly.) This is leading me to believe there is something wrong with the current Picroft image online. Is anyone else running into this issue?

going through your code, I think the failed intent is because of a syntax error in your code here https://github.com/dleweyiv/HandMeSkill/blob/master/init.py#L23. In your intent handler you have self_speak_dialog(“hand.me”). It should be self.speak_dialot(“hand.me”). There is no underscore between self and speak. Hope that helps.

1 Like


You are right there was an error in my code. I fixed it and removed the old skill and added the new one with the fix, however I am getting the same error. Inside the logs it is labeling the intent type as “intent_failure” which I believe to mean it cannot correctly recognize the intent.

If you have any more suggestions I would love to hear them! thanks

I even tried installing the flip-coin skill from https://github.com/wligtenberg/coin-flip-skill and I am having the same issue with this skill

Hey @dleweyiv, can you post the debug logs here so i can take a look? also make sure you are running the latest picroft image, but doing a sudo apt-get install mycroft-core and sudo apt-get install mycroft-picroft