Picroft - Failed to connect to network

PiCroft: 21.2.0
Raspberry Pi 4 - Revision: d03114

From a fresh install of the zip downloaded from github. Initially I setup a wired connection but it was undetected although it had a valid link and got an IP. I am now testing with Wifi and getting the same result. I get an IP and connectivity works as expected but on every boot I am prompted to configure networking.

I have tried option 1 and entered SSID and PW.
I have tired option 3 and verified the information.

Both options successfully connect to the network but the wizard reports that it is unable to detect the network. If I select option 5 (Skip network setup for now), I can proceed with the rest of the wizard without issue.

Every reboot I am prompted to configure the network.

Which logs can I check to see what is causing the wizard to not detect the network?


In: auto_run.sh

while ! ping -q -c 1 -W 1 >/dev/null 2>&1 ; do # check for network connection

I block outbound ICMP to that address apparently.

1 Like

Ah thanks for posting why.

How best to detect a network connection has been debated many times though I’m not sure those have made it into this Picroft script. This is simple but generally works.

This also happens on a setup I have here, but I suspect for a different reason. The wlan interface just takes a bit too long to come up, so network detection fails when it reaches that ping line, although if it retried several seconds later, it probably would work. That said, not sure it’s worth fixing at the moment.

1 Like