Pi3, Kinect360, UbuntuMate, 3.5mm Speakers = Success!


Brand new to Mycroft, so if this has already been done, my apologies. I just thought it was kinda fun to solve.

I had a Kinect (v1 from Xbox360) laying around. As it has a really decent mic array, I thought I would find a use for it. Enter Mycroft.
After screwing around with raspian and picroft I came to the sad realization that the mic array could not be employed on that OS. But i really wanted to use the Kinect, so I turned to Ubuntu Mate.
I put Mate on the Pi then removed everything extra. Added pulseaudio controls, install freenect and Kinect-Audio-Setup. I forced sound to the 3.5mm jack and tested. It all worked.
Then I followed the instructions for a git install. After sorting out some odd permissions and several installs/re-installs I finally got a clean install and the mic array worked great. But no sound. After much searching I came across a post and I removed the default sink and forced it to the Pi’s onboard sound. No sound but re-forcing it to the 3.5mm jack gave me a successful audio test.
Bringing Mycroft up in debug, I ran tests to adjust the volume and mic inputs till I was happy with the results. (Side note: The mic array in the Kinect is REALLY good, very sensitive.)
A reboot gave me grief: no sound. Somehow, the volume got muted (WTF?) and of course that was the last thing I checked (D’oh).
Reset volume, check the devices availability, reboot and we’re golden.

An Rpi3 running Ubuntu Mate with Creative Desktop Speakers (good sound) and an Xbox 360 Kinect as the microphone array.



Welcome @Fred_Thomson, and cool contribution!

Thanks malevolent. It was an interesting challenge.

I should mention that the permissions problems came up probably because I clone the mycroft-core in my user directory and had a b*tch of a time figuring it out. I finally used the shotgun approach and changed the whole dir to be owned by user. It may not be the best solution but it did solve the problem.

I think that once I get more familiar with this, I may install Ubuntu Server 18.x LTS on a Pi4 and give Mycroft more horsepower.