Pi 4B installation nightmare


First off…wonderfull project! *if it works…I hope…I really hope!

I’m having a nightmare installing the Picroft initiative tho…


-Pi4B 4Gb
-Playstation 3 eye
-3.5 jack plug output speaker
-Realtek USB Wifi dongle

Ok, here it goes:

Yesterday I tried installing the Picroft image using the stable version of this link: Picroft - Mycroft AI

I first installed it with a network cable attached and it went fine…untill after the succesfull sound test…and pairing, I could scream ‘Hey Mycroft’ as loud as I could, but nothing…silence…total silence… to make matters worse, I tried to go from a cable to a Wifi-setup, saw on the same page (see link above) that Mycroft doesn’t work from 5Ghz Wifi, so I tried to use my USB-Wifi-dongle it would not connect, no matter what I tried.

So today, I just tried to reinstall it all, I did remove the USB-Wifi-dongle, rewrote the image, then again wifi failure *using the standard pi4 Wifi, just skipped that…and continued…now I did have Mycroft say something! *because of the no-Network I skipped the update to latest version… from there I was in the cli interface…there finally was also a number next to the microphone-meter but nothing… no reaction when I said ‘Hey Mycroft’… then I typed in ‘help’… Mycroft spoke and said it wasn’t done booting…after like 20 mins…

So…then I did a sudo reboot, skipped the network setup again (since it couldn’t find my 2.4 Ghz SSID) and ran a Wifi scan with the sudo command…it did find all my 5Ghz SSID’s…so I rebooted and chose option 3 for wifi and adjusted the name of the 5ghz SSID…and…was in business…Wifi-wise.

Then Mycroft began to update…a true color-fest, red, orange and white…asked me to continue after some failed stuff (no option to retry)…after completing what it could I did a reboot, it couldn’t find the Wifi…opted for option 3, changed nothing and hit ctrl-X…then it connected with Wifi…and couldn’t resolve github.com and got a ModuleNotFoundError on a module ‘lingua_franca’…I guess this could be right since I know no France…

Ok, so I’m quite the optimistic guy…but really, what can I do to make this work?

Please help! *I’m not really Linux tech savvy…but mostly do get things done :wink:

I don’t think the rpi4 is currently officially supported. But with that there are a couple unstable and/community builds that people have had success with. I would recommend trying the build by @j1nx
MycroftOS - A bare minimal (production type of) OS based on Buildroot

Bare in mind, MycroftOS is NOT based on raspbian.

Alpha7 however does support all your listed hardware out of the box. 5ghz wifi is not yet picked up by the wifi wizard (on the todo list) which is most likely caused because the lacking of country code within the wpa_supplicant.conf file. 2,4 is no problem and most likely adding the country code manually to above file afterwards will work (not yet tested because I do not own 5g equipment yet)

1 Like

Thnx for the replies!

However, the page I got the image from says this:

" Hardware requirements and compatibility chart

Model Level of support
Pi4 Supported
Pi3 B+ Supported
Pi3 B Supported
Pi 2 Functions very slowly, limited wifi support
Pi B Not supported
Pi A+ Not supported
Pi Zero, Zero W, Zero WH Not supported

*So now I am Confused… :-/

Confusing indeed, as the top of the page says

Picroft is a ready-made way to run Mycroft on a Raspberry Pi 3 or Raspberry Pi 3B+ and is provided as a disk image that you can burn to a Micro SD card.

Not sure now if the picroft image also can be used for rpi4

Edit; Let’s tag the documentation master from down under😝 @gez-mycroft

Ok thnx! Hmm, so if I would install your MycroftOS version, would I still be able to:

  1. implement a custom wake word
  2. ‘teach’ Mycroft things
  3. implement it with Home Assistant
  4. will it be updated along with the ‘default’ Mycroft version?

Furthermore, what does the ‘unstable’-version of the ‘regular’ Mycroft mean? Is that like a beta? And is there a description in where that differs from the stable version?

Sorry for all the questions, really would like to get this working :wink:

I am pretty confident you will get this working, this is a great community and there are plenty of people that will help you succeed. Many people here are also part of the Home assistant community (myself included) so I can confirm that it will work with Home Assistant.
Welcome to the community and hang in there you will get through this.

  1. Yes, the same functions are available as long you do not want to train a precise wake word but the again that is also not supported by picroft.

  2. Teach, as in installing skills? Yes, no problem. There is also a “learn skill” if that is what you mean.

  3. yes, you can just install the home assistant skill. You can’t install home assistant itself, but that is really not recommended anyway as it stretched the system resources. Precise is rather demanding and over time home assistant as well.

  4. No, not yet. Or at least not without reflashing a new(er) firmware. I have not yet implemented that part. Still figuring out the best way forward for the best embedded (OTA) upgrade architecture. As MycroftOS already looks very similar as HassOS, I thinking about also using RAUC for it.

Just get a vanilla rasbian-lite and use the above.
It just installs rather than being an image and to be honest much prefer it.

cd ~/
git clone https://github.com/MycroftAI/mycroft-core.git
cd mycroft-core
bash dev_setup.sh
1 Like

Thnx for the info! Really appreciate it!

It seems tho that I got the 5Ghz Wifi working, I needed to change the Country from US to NL…and I had the metal cooling rib-things on the chips (that seems to be able to interfere with the WIFI)…not sure which was what, but I did a ping www.google.com when country was set to US…got a lot of missing packets. Changed it to NL…now all are received. My theory is that that caused the initial update to go ‘haywire’…

1 Like

Another update:

Rewrote the stable image again and reinstalled:

  • chose option 3 for wifi
  • altered country-code and added network ssid and psk
  • seemed no good, did a sudo reboot
  • chose option 1 added the same info again
  • no good, another reboot
  • chose option 3, removed the old network bracketed stuff, leaving country code and automatically added ssid and pkey (from option 1)
  • said ok, network connection super
  • ran trough the setup wizard, selected 1 for the playstation eye
  • just when I hit a key to start test it began the update process
  • then afterwards again the test…no go
  • reboot, mic no go, but did get Mycroft to speak and pair (no mic-level)
  • reboot mycroft-cli-thingy (mic level static, get all kinds of weird status text on the screen, saying error 88 and 111 connection refused

*Thought I was nearly there… lol

*Edit: did the mycroft-mic-test, mic now works… *it’s something :wink:

*Edit2: After another reboot…it works! *Yay! *keeps fingers crossed for keeping this working…

1 Like

Update 2 *Mycroft is really awesome btw!! :wink:

  • I get the: “mic level static, get all kinds of weird status text on the screen, saying error 88 and 111 connection refused” again and this is when I type in mycroft-cli-client directly in the terminal. However, when I log in with putty and get the cli-interface it works just fine. *This might be a bug?!

  • I did place the cooling rib-things back, and the Wifi signal is still ok, so the Language must have been the culprit…


Thanks for that, all fixed up :slight_smile:

Hi I’ve been trying to get the latest picroft stable ima gf e running on a Pi4b and it says the board needs new software.

Wondering if you got it to boot and if if you used the stable or unstable?

Have you thought about an OS other than Picroft?

I’ve been using Ubuntu Desktop 22.04 (as it is a good general purpose OS). I’ve seen none of those problems.

Here’s a doc: https://github.com/mike99mac/mycroft-tools/blob/master/smartBoombox.pdf

Hope this helps.

-Mike Mac