Phonemes problems

Having trouble defining phonemes for christopher.
Any suggestions?
Also when i edit mycroft config user file it seems to get overwritten with Hey Mycroft precise.

I assume this is dinkum on a mk2?

dinkum moved the order of configs, now remote takes precedence over system and “old user”

“old user” is still in a lot of documentation and is ~/.mycroft/mycroft.conf

system is "/etc/mycroft/mycroft.conf and also used to have priority over remote (for very good reasons…).

while ww selection has been removed from selene, it still pushes a hardcoded “hey mycroft” wake word, this means that the only place you can change ww in dinkum is ~/.config/mycroft/mycroft.conf

relevant code:

relevant discussion:

Sorry, should have made clear I’m using a raspberry pi3B with mk1 aiy hat

anything in logs about config failing to load? if hey mycroft is taking precedence over user config and its not dinkum then probably theres a syntax error and the config is not loading at all

I’ve checked there are no errors in file. If there is an error you are informed before file saved. What’s strange is that when you go back into config the mycroft wake word with pocketsphinx is back in at the end of the file. Neither mycroft or new wake word respond in pocketsphinx.

This is what helped me set the wake word to pocketsphinx and Christopher

  "listener": {
    "wake_word": "christopher"
  "hotwords": {
    "christopher": {
      "module": "pocketsphinx",
      "phonemes": "K R IH S T AH F ER .",
      "threshold": 1e-18

David thanks for the reply.
Did you change the config file via
Mycroft-config edit user on the Pi itself or via SSH on a pc?
I tried something similar on the pi and it was overwritten with Hey Mycroft again
I also found that after reboot I was back on precise.
Is your system built with the latest stable image?
I’m interested to know the exact process of how you managed to get ‘christopher’ as the wake word up and running.
Thanks again for the reply

David edited mycroft-config edit user exactly as your example. There were no syntax errors reported.
After exiting edit and restarting mycroft and checking the user file again the file had been overwritten with hey mycroft pocketsphinx info as others have reported. How did you keep christopher info from being overwritten?

Seems to be solved. Edited config file by ssh. All good Pi now responds to christopher. The Pi responds perhaps two out of three calls. This could possibly be down to my Northumbrian accent:-).
Thanks Dave for the info