Pandora/pianobar problem with mark-1

  • The specific Skill name and GitHub repository

skill(s): pandora & pianobar from mycroft-core 21.02.0b updated as of 28-jun-2021 (apt update; apt purge mycroft-code; apt install mycroft-core mycroft-mark-1)

  • Which Device (ie. Picroft, Mark I, Linux) you are using


  • What you’ve already tried to do to resolve the error.

I have a paid pandora account.
When I downloaded the latest version of the sdcard image, installed the pandora skill and created the pandora account info at everything worked for a while. After a couple of days when I tried to play pandora again, I get the audio message that I need to go to and enter my information.

After repeated tries, it still fails…

I then decieded to try logging into pianobar directly using the cli. Then I tried to play pandora using mycroft-cli-client and IT WORKED???!!!

Do you have any suggestions on how to start looking into things to try and identify/fix the problem in the pianobar/pandora skills?

I have lots of linux/rpi experience but have not done any work with mycroft other than as a user.


1 Like

Also having the same problem. It’s like the pandora skill just loses my login information. I suspect a caching problem, but I don’t know how to force invalidate and renew the cache without uninstalling.