Pandora music skill

Installed pandora on picroft raspberry pi 3b+, updated skill settings in pandora skill to include log in credentials. saved & restarted picroft.

Command to play pandora seems to work ok, says it is playing classice rock on pandora, however getting no sound at all out of speaker. Speaker works fine on everything else. can anyone advise possible fix.


Have you tried the solutions here? If so, it might be worth posting an issue at that repository. I can do that, if you aren’t familiar with GitHub.

I have exactly the same issue. Did you find a solution?

I’m not sure why, but I found pulseaudio to be the problem with Pandora. Once I uninstalled that, it works fine. And this is only for picroft, Pandora and pulse seem to work fine together on all my other instillations.

1 Like

Even I am facing same issue. Any solution?

I am using Oontz bluetooth speaker. I have also tried changing speaker.

Hi All, love the PiCroft Project! Above every skill though, I love being able to control Pandora with it! :slight_smile: I updated my Pi however, and afterwards I cannot get the skill to work anymore. PiCroft keeps telling me to setup the skill in mycroft,ai, which have done multiple times, but still will not take.

I tried uninstalling and reinstalling the skill, and a bunch of reboots. Kind of new to all this so not sure what else I can try to correct. Any ideas/guidance? Anyone else experiencing?

Sorry all, I found a different thread with the same issue and trying what was suggested for the solution by @vinnywright: Pandora skill asks for registration

You need to add your Pandora user ID and password in the Mycroft settings at