Pairing Desktop

Hello - new to all of this - got the repo from GitHub, set up the environment … got mimic installed, …
used ./ start …
Mycroft service started
Mycroft skills started
Mycroft voice started
Mycroft cli–quiet started

Cleared all logs …

tried to say Hey Mycroft what time is it … and get this

2017-02-20 09:09:51,125 - ConfigurationSkill - WARNING - Impossible to update configuration because device isn’t paired

Went to web site to add new device - and it wants a registration code …

  1. Do I have to register to pair?
  2. How do I get a registration code?
  3. Am I missing anything else?

Thanks for any and all assistance.


  1. yeah, to use our proxies. Go to to register an account
  2. It should speak the code, show up in the cli and in the skills service logs. Find these in scripts/logs
  3. I don’t think so, if it heard you, do you get any sound output at all?

Try attaching to the cli client in screen and typing “pair my device”

Thanks … that seemed to work … attaching to the cli client in screen …

I have had to register again lately … but that worked … the web interface says you cannot “unregister” a device … is this true?
There seems to be greater latency if I do not run the cli attached to a screen … is this common?

You can delete your devices on the devices page on

If you click on the device to see it’s details, there’s a remove device button.

Where did you see that you cannot “unregister” a device?

hey aatchison,
Would you mind stepping through how to attach to the cli client?

Will I need to install screen on my Mark_1 enclosure?