OpenVoiceOS WSL installation

Does OVOS really work on WSL? I tried Ubuntu 20, 22, 24 but none of these worked. Always getting error caused by reaching docker pull limit. Maybe one of the reasons is that in installation UI I am able to move with cursor using arrows but my selection actually nothing changes and it always offers me just default installation (using containers not virtualenv). I guess that can be part of the problem as I do not have paid docker account.

Is the UI not really working for WSL or what can cause the problems?

It’s been a while since I tested in WSL, several months, but it worked last I tried. Not sure why the installer TUI isn’t working for you - maybe @goldyfruit can shed some light?

Regarding the docker pull limit, you can double it by adding an authenticated free account, which should be more than enough for OVOS.

1 Like

Thank you, setting up properly my docker helped. I am still not able to adjust the installation but that ok atm.

I havent fount info, how to run OVOS on wsl2 after instalation. Can you help pls?