No speech output

I’m brand new to Mycroft and installed it using the Github instructions on a Ubuntu guest on an OS X host using VirtualBox. When using it with CLI I can see that Mycroft hears my speech and responds appropriately with text output, but there is no speech output. I know the speakers are working (I can hear the ding of Mycroft responding to the wake word). Tails for the voice and audio logs are at Any assistance would be greatly appreciated. Thanks!

@Raj1 do you have mimic built? to check go to the Mycroft-core/mimic directory. There you can do ./mimic -t "hello world". You should then hear mycroft say “hello world”. If not then you most likely do not have mimic built. You can run ./dev-setup in the mycroft-core root directory again to build it.

Hope that helps

That solved it, thank you!

1 Like

I have similar problem (docker on Linux). Voice is recognized, ding is heard, yet I see answers only in “ debug” window, no speech output.
mimic works properly. This happened after I tried to switch to google synthesizer and then back.
“stt”: { “module”: “mycroft” },
“tts”: { “module”: “mimic”,
“mimic”: {
“voice”: “ap”
“mimic2”: {
“lang”: “en-us”,
“url”: “
“espeak”: {
“lang”: “english-us”,
“voice”: “m1”

I suspect REMOTE is set wrongly and overrides correct settings in the conf file. How can I see value of REMOTE config?

My mistake, sorry - Mycroft home still had google tts specified. Changed it to mimic, had to restart mycroft and now it speaks!

1 Like

I seem to have the same problem – I hear the ding, I get CLI responses, but no voice. I tried both changing TTS in the config file to mimic2 and compiling mimic1 locally, but none of that helped :-(. I can’t see any log messages on the console regarding voice output. Any other ideas?

Hi there, I wanted to check, after compiling Mimic 1 locally, have you set the voice to British Male in your device settings?

It should automatically fall back if Mimic2 fails, however explicitly telling Mycroft to use British Male should stop it from attempting to use other services first.

Any TTS logs should be written to: /var/log/mycroft/audio.log
So worth checking that to see if there are any clues as to what’s going wrong.

Thanks! Yes, I’ve set it to British Male.

The audio.log file was strangely only used the 1st time I ran Mycroft (and contains an error message about failing to find mimic), but on the next runs, no other messages appeared there. All the other log files show a lot of newer messages, but not this one. The permissions are set exactly the same for all of them :-/.

Sounds like the audio service is failing to launch at all.

Can I confirm how you installed Mycroft?
Is this a linux version using git clone, a Picroft image or something else?

Sorry, I had some pressing issues and got distracted from trying it out more. I’ve only got back to it now. It must be an issue with PulseAudio and my soundcard. With a system & Mycroft update + this fix, it seems to work (at least basic TTS responses, I haven’t tested Spotify or anything more complex yet).

My configuration is RPi4 + ReSpeaker 2 Mics Pi HAT + Raspbian + Mycroft installed from git.

1 Like

Hey guys, I got the same Problem and tried everything I understood from this forum…
Audio is correct, mic is working Mycroft is working but the Voice is not and Mimic is installed.
It worked for like 3min. I use a DietPI.

Did you try to switch the voice via
In my base British Male fails with an error stack in /var/log/mycroft/audio.log each time it tries to speak, but American Mail and Google Voice work fine.

I’m having the same issues. The verbal audio is unreliable, Mycroft’s verbal audio came back randomly without editing any config files. What config file were you referring to?