No sound on wakeword recognition

Mycroft (Picroft) detects wake word but doesn’t make a confirmation noise. I’ll say, “Hey Mycroft” and will hear total silence, but if I go on to give a command, it’s responsive.

How do I set the wake word sound?


Hi there @DerekCaelin, I’m ruling out a volume issue here because the volume is OK when Text To Speech activates.

The Wake Word file itself is stored at;

ie - on your Picroft you’ll find the WAV file for the Wake Word “ding” at this file path.

Has this been modified at all?

Your logs may also have some clues as to why the Wake Word sound isn’t “dinging” - if the Raspberry Pi can’t play the WAV file for example then it may not play - for example if a library or a package is missing.

I had this problem and did a little digging…

For some reason the ~/.mycroft/mycroft.conf had been changed to confirm_listening false.

Change it to true and the problem is solved.


Hi folks,

Thanks to you both. I attempted to solve via @cbxbiker61’s solution but my mycroft.conf file doesn’t reference “confirm_listening”.

“play_wav_cmdline”: “aplay -Dhw:0,0 %1”,
“play_mp3_cmdline”: “mpg123 -a hw:0,0 %1”,
“enclosure”: {
“platform”: “picroft”
“tts”: {
“mimic”: {
“path”: “/usr/local/bin/mimic”
“ipc_path”: “/ramdisk/mycroft/ipc/”,
“hotwords”: {
“hey mycroft”: {
“module”: “precise”
“SkillInstallerSkill”: {
“path”: “/opt/venvs/mycroft-core/bin/msm”

I haven’t touched the “wake word” file, either.

Will keep poking around…

Hey @DerekCaelin is this still occurring for you?

I ended up reinstalling picroft. At this point, my mic is no longer detected, so technically this issue is resolved! :slight_smile:

Oh, technically resolved, but not exactly a great outcome!
What sort of microphone is it? Anything in the error logs?

I am having a similar issue with Mycroft on Ubuntu 18.4
When I downloaded and ran, it worked great! when I restarted the service however; it no longer gave the ding after the wake word. Everything works and follows command just no ding. I confirmed I have the .wav file and I did check the config file as noted above and it does say “confirm_listening true”. Where else could I look, or what log would be helpful to look at?

I can confirm this behaviour in Picroft Unstable 2019-09-26 image
After rebooting it does recognize the wake word, but prompt it not anymore.

Isn’t there a solution for the problem yet?

Maybe there’s a connection: in the voice.log I got an error every time when I speak the wakeword:
2020-03-13 12:47:53.994 | INFO | 778 | main:handle_wakeword:69 | Wakeword Detected: hey mycroft
Too many arguments.
(The main has two typical python _ _ (without space) at the beginning and at the end. Editor killed them)
What does this error message mean?

2020-03-13 12:47:53.994 | INFO | 778 | __main__ :handle_wakeword:69 | Wakeword Detected: hey mycroft

Basically mean that the wake word was detected. The second line “Too many arguments” I don’t know where it could come from. If the “ding” isn’t playing then it could be the playback command that’s failing and printing that.

What system are you running?

Raspberry Pi 4 with 4 GB memory, Picroft 20.2.1 (master), sound managed via pulseaudio to a usb-soundcard. I’m working with a headset, mic and speakers are ok. The audio system in general is working fine. I’m only missing the sound after hey mycroft and after end of speaking. As long as i can see the logs at the mycroft-cli-client I know, if picroft has recognized my speech. But in future the Pi should work “headless”. So I need acoustic feedback.

I had the same problem, the line in ~/.mycroft/mycroft.conf had been changed to
confirm_listening false.
I don’t know why it occured, but here’s how it happened:
Yesterday, I told mycroft to set an alarm for today, at 08:00.
The alarm went off today at 08:00, as it should.
Afterwards, there was no notification beep when speaking the wakeword.
The timestamp on the mycroft.conf file indicates it was changed at 08:00 today.

Chaning the line in mycroft.conf to confirm_listening true and rebooting solved the issue.

Yeah I had the same thing happening today!
Mycroft woke me up for the first time. And then the whole day the wake-up-sound did not “ding”. But the .wav-file is there and the mycroft.conf file is also fine (confirm_listening true)

What can I do??

Try this:

Both file types .wav and .mp3 must be routed to the correct audio hardware.