No registration code after snap install ... "please wait a moment as I finish booting up"

Good Evening,

I Installed Mycroft via snap package on my elementary os. Unfortunately I’m not able to obtain any registration code, and the program seems to be stuck on “Please wait a moment as I finish booting up”.

How can I move on? :slight_smile: Thanks in advance for your help!


Hi Luca,

I ran into the same issue trying to install the snap. I mistakenly thought it would be harder than using github. I was never able to get the snap to work beyond the point where you’re stuck now.

It only takes a few minutes to set up and everything worked.

Good luck!

1 Like

The snap isn’t well supported, and the github method is much preferred to get working.

1 Like

Wouldn’t it be better to remove the package or, at least, warn people of this problem? :sweat_smile:

Thanks guys, i’ll try compiling the program :slight_smile:


1 Like

No idea who maintains the snap, so…?

I may also have this issue. I am not a native user. Someone suggested Simon however Mycroft appeared to be the more current application and had an active community. The only other choice really that was fast and usable was google chrome. I am not looking for internet of things, just voice to text really, but prefer to use open source. I don’t like to support big tech companies too much and I believe in open source.

I am thinking to uninstall, how long should you give the install?

How hard is it to install manually? I just checked the posted link above and it’s all dutch to me. I dont even have a microphone set up yet I just wanted to have a look and have a go.

Which platform are you trying to use? For instance I am using an Ubuntu PC.

For me the snap approach was a total fail. At the same time the github install was a breeze. Not counting my time to read about git, Mycroft install from git took perhaps 60 minutes but I wasn’t timing it. That included me working through getting a Mycroft account, etc.

1 Like

Yeah sadly the Snap is not working so far.

Hey, we adopted the Snap from a community member with the intention to get it up and running. Fixed a whole lot of bugs and it’s now tied into our CI process so it will receive any general updates but unfortunately there are still some major usability bugs. In the meantime I’ve added a warning in our docs and the main website to direct people to the git clone method for now.