No module named "mycroft_bus_client"

Hello !

I started working on mycroft about a month ago and now trying to work with the messagebus but i’m faced with an issue that had me stuck for the past few days.

I followed the instructions on this page : MessageBus

and whenever i launch mycroft i have an error telling me : “ModuleNotFoundError : No module named ‘mycroft_bus_client’”

I tried to see if the issue was linked to python, my proxy or anythign else but no luck so far

If anyone has any clue as to what could be the issue…
Thanks in advance


the page doesn’t explicitly state it but this is a separate module for use when interfacing with Mycroft. It requires you to install the module in the virtual environment (or possibly the global environment)

pip install mycroft-messagebus-client

before being able to use it.

I installed the module with the help of pip but i just realised that this error shows for every new module i try to install (i tried to implement websockets and got the same error)

I just realised my mistake, I needed to use mycroft-pip Now it’s working :+1:

1 Like

Thanks for flagging this, I’ll add an explicit install instruction :smiley:

1 Like