No audio responce new installation SOLVED


New user and just finished my new installation of mycroft in a lenovo laptop, running debian testing.
Followed instructions and installed through git clone the master branch and run the with no errors.

After installation started mycroft and get no response from him.
Went through both troubleshooting guides ( audio & wake word troubleshooting) run all checks and tests and both input and output devices seem to work perfectly.

When I run mycroft in debug mode, I can see the level of my microphone in the lower right corner but no response from mycroft.

Below is the pastebin for my audio.log

would you check /etc/mycroft/mycroft.conf? I suspect tts.mimic is linked to a wrong place.

@SGee thanks a lot for your reply.

So in my case there is no /etc/mycroft/mycroft.conf file.
There 2 mycroft.conf files in the following folders:

  • List item /home/user/.mycroft/mycroft.conf

  • List item mycroft-core/mycroft/configuration/mycroft.conf

I checked both files and run a search under “tts.mimic” and nothing returned.

Can you try to be a bit more specific what I have to change. Keep in mind I am a new user…

thank you

then it should’ve went into .mycroft/mycroft.conf.
I suspect the path is not where you installed it.

 "tts": {
    "mimic": {
      "path": "/home/gui/mycroft-core/mimic/bin/mimic"

I am pasting the mycrof.conf part that refers to tts.mimic


I don’t see anything like you mention. The mycroft.conf file is under the mycroft-core folder after all not under the .mycroft.

Last but not least in my mycroft-core/ folder I don’t have a mimic folder as in the example you gave me.

thank you

ok, i deduct that you have skipped the local mimic build during setup.
Yet the tts module is set to “mimic”, not “mimic2”. try to change that.

that said, you shouldn’t do this in mycroft-core/mycroft/configuration/mycroft.conf,
this is what the .mycroft/mycroft.conf (user) resp. /etc/mycroft/mycroft.conf (system) are for

in which part of the file, there are 6 mentions of the word “mimic” in the mycroft.config file. 2 of them already mention “mimic2”.

thank you

what’s in this file?

“max_allowed_core_version”: 20.8

just this

scary looking but those (2) will send the specific lines into mycroft.conf (without me explaining json)

json=$(cat /etc/mycroft/mycroft.conf | jq '.tts = {"module": "mimic2", "mimic2": { "lang": "en-us", "url": "", "preloaded_cache": "/opt/mycroft/preloaded_cache/Mimic2"}}' )

echo "$json" | sudo tee /etc/mycroft/mycroft.conf

check it afterwards :wink:

Ok we got somewhere… so I entered your 2 liner and rebooted.

Starting in debug mode now mycroft responds but not in the wake word. So in example if I write in the terminal set timer he asks " how long of a timer? " and if I tell him “5 minutes” he starts the timer.

Any ideas? Should I keep this thread here or open a new one for the wake word?

not sure what hardware you are using, but likely another case of pulseaudio/alsa not playing along. check voice.log

Here is the voice.log

Regarding hardware I am using and HDA Intel PCH

the wake word is detected, but without confirmation output it seems. aplay some wav file. I’m guessing mimic 2 is sending mp3 (which is played with mpg123)

yet this

2020-11-11 11:13:25.247 | INFO     | 77226 | __main__:handle_record_begin:37 | Begin Recording...
2020-11-11 11:13:26.467 | INFO     | 77226 | __main__:handle_record_end:45 | End Recording...
2020-11-11 11:13:28.703 | INFO     | 77226 | __main__:handle_utterance:72 | Utterance: ['ip address']

would indicate that you hear it, just don’t have the right sequence of words to trigger a skill

Ok so I did

arecord -d 10 test.wav
aplay test.wav

and everything works.

see edit above …

Yeah my mistake, that is from yesterday, check the timestamp… so a quick timelne

Initially when I did the install I could wake up mycroft/jarvis but after that he could not respond.
Today after boot up the system did not respond at all so I posted in the forum and you helped me fix the issue.

link the new /home/r2d2/.mycroft/mycroft.conf again please, there is a failure


as after the 2 liner

and changeback to hey mycroft as
2020-11-12 15:08:27.926 | WARNING | 5466 | mycroft.client.speech.hotword_factory:initialize:417 | Could not found find model for hey jarvis on precise.