New update my skill brakes all but 2 other skills


I am working on building my own skill, and all was working well until the new update, now when i place my skill folder in to the skills folder all but 2 of the other skills stop working the weather skill and the ip skill. my skill is called ListSkill at the moment when i take my skill out of the skills folder and reboot all of the other skills work again.

when i originally did the update my skill worked but it was in the skills folder when the update happened, but i updated one of the critical python file versions and mycroft stopped working so i unpacked the 0.8b version and started fresh but now it does the update before i can copy my skill in to thew skills folder. any ideas why this is happening?

i just renamed my skill and more skills load but still not all skills and the skills log crashed saying “ImportError: No module named init

but there is one in every skill folder.

I have tried a few more things but with no success. I changed permissions on my skill folder to anyone and tried another skill that I downloaded the “response_test” skill an example of how to use the expect_response switch. and the same thing happens.

any suggestions or help would be greatly appreciated.


hey again,

I have found that the permissions on the folders were set to anyone but the files were set to read by owner only so once i set the read permissions to anyone that fixed the problem, i did not think that they would change by copying them to a usb drive to transfer over to the new mycroft install.