New picroft install failed overnight

I set up a picroft on a Raspberry Pi 3 with a PSEye a set of USB soundcard speakers and left it running overnight. I returned to it this morning and the system had stopped working. I rebooted it and logged in over ssh to see that the cli client was failing with an error in the python certifi package because it seemed to have been upgraded and was now showing all the files as being the dpkg-dist versions. I fixed that and started the cli client again, and started getting this error:

11:09:06.144 - - ERROR - Exception closing websocket: Exception("Uncaught 'error' event.",)
                                                           11:09:06.162 - - WARNING - WS Client will reconnect in 60 seconds.

Picroft is not responding at all.

Any help to at least get it back to a working state would be appreciated but I have to say that I’m not very confident with this as a product at the moment.

Hi there @sfgreenwood, sorry to hear your Picroft install isn’t working yet.

So that I can better assist you with troubleshooting, are you able to confirm for me please;

  • What method of install you used - for instance, did you burn the disk image to Micro SD card?
  • Whether the Picroft setup was working before it was left running overnight
  • Which version of Picroft you installed
  • Whether there is anything in the logs at /var/log/mycroft-* that might provide a clue as to what’s going on?

We understand your level of confidence, however Mycroft is currently in beta - and being actively developed. New releases of mycroft-core ship every fortnight - and it gets better all the time!

Best, Kathy

Hi Kathy -

It was copied to a MicroSD from the current downloadable image as of Wednesday.
Speech recognition was working and responses were going to the CLI but not to the speakers (this is another issue - all other output seemed to be working apart from the voice responses).
I can’t see anything obvious in the logs apart from the issue with certifi.

I had it working with a cheap set of speakers in the RPi audio out but I don’t think the issue with the messagebus error is related to switching to the USB out - the alsa and pulseaudio settings all seemed to be correct for the hardware and everything except voice responses were working until logging in this morning.
This is what is in /var/log/apt/history.log:

Start-Date: 2018-04-27  10:02:38
Commandline: /usr/bin/apt-get install mycroft-picroft -y
Upgrade: mycroft-picroft:armhf (18.2.4, 18.2.5), mycroft-core:armhf (18.2.4, 18.2.5

Thanks very much for that information, @sfgreenwood, that’s very useful.
I’m going to ping my colleague @forslund to see if he has any suggestions.

The first error message suggest that the mycroft-bus process isn’t running. (the other processess can’t connect to it atleast.

Please check /var/log/mycroft-bus.log for any error messages. Or try running sudo /etc/init.d/mycroft-bus start

1 Like

I looked at the Pi this morning and the messagebus error had stopped. Rebooting made it work as previously. Could it have been a backend communications error?

Glad to hear it started to work again. It’s hard to say a definite cause here, I don’t think the backend should have been involved. My theory is that the messagebus service didn’t start for some reason, but I have no real idea why… :confused: