New and ready to learn!

Hey all! I’m new to the forums as of today actually! I have known about Mycroft for a while, but didn’t get seriously interested until here recently! I’m on Ubuntu 16.04 and installed mycroft-core via git. It seems to install and start fine but Mycroft won’t respond, I can’t find the ‘identity2.json’ file, and when I run the ‘screen’ that outputs ‘mycroft services’, it keeps giving me this:

Starting service
2017-06-12 17:49:38,373 - mycroft.configuration - INFO - Loading configuration: /home/breana/mycroft-core/mycroft/configuration/mycroft.conf
2017-06-12 17:49:38,420 - mycroft.configuration - INFO - Loading configuration:
2017-06-12 17:49:40,546 - mycroft.configuration - WARNING - Failed to fetch remote configuration: HTTPError(u'The supplied authentication is invalid',)
2017-06-12 17:49:40,547 - mycroft.configuration - INFO - Loading configuration: /etc/mycroft/mycroft.conf
2017-06-12 17:49:40,547 - mycroft.configuration - INFO - Loading configuration: /home/breana/.mycroft/mycroft.conf

Any Ideas? Thanks so much!!

Have you paired the device?

Thank you for replying to me. I did pair with the code CLI gave me, but it still says to pair device. Now I will mention that last night before I got that I had nothing… no sound effect when saying “hey mycroft” or anything. I did install via the apt package yesterday, and things seemed to be running more smoothly. But, I was wondering since I had previously installed via git clone, and had not removed those files, if the two installations could be working against each other… If so, How to remove all mycroft files and start over? I will say that when using CLI, I see replies to time, weather, and it even read me the news once, after typing the command, not speaking. So I feel it’s just a few things I need to work out? Id addition, the GNOME extension says mycroft is disabled? Hopefully. Ready to get this installed and working good, and start building/installing skills. lol

So it sounds like you’re close.

If the gnome extension says Mycroft is disabled, you should be able to click the play button to start it up.

If you want to start over, I would try removing everything you have so far and install it using the extension. It just does a github clone and build, so shouldn’t be any different than what you have now, but is a bit easier to interact with.

Okay, nothing happens when I press the Play button, for some reason. When I did the pkg install it added a user ‘mycroft’. I can’t login to that user, but it still shows as a user. And, if I did want to remove everything and start over… what all would I need to remove? The user, mycroft-core, .mycroft, etc.? Sorry if I’m asking dumb questions lol

I once had the same problem that after pairing the device asked again or pairing. Tried it several times but then I just installed the whole system new, set up mycroft again and then it worked.

1 Like