New aggravation - Mycroft bleeping as if addressed when he hasn't been

Mycroft has developed a new habit. When the room is quiet, he will bleep as if he has heard “Hey, Mycroft”.

If I give him a command at this point, he does it. This is a problem when the room is quiet, but running the computer is enough noise that this does not happen. The air conditioner works also. I can say “Hey, Mycroft” as usual and ask for things.

If the pattern holds through the day, Mycroft is bleeping hundreds of times in the time I am at work.

Thanks for reporting this, @mwgardiner. It sounds like one of two things;

  • The microphone gating is too sensitive
  • Or the Wake Word sensitivity is set to too sensitive

Has your Device been altered from defaults at all? Knowing this is a good starting point for me to assist with troubleshooting.

Best, Kathy

The only changes from defaults are my location, changing the eye color to green, and setting the mouth to display time when idle. I have not knowingly changed anything else. I’ve installed a few skills, but I think it unlikely that would have this kind of effect.

Thanks @mwgardiner, agree - the Skills should not have had this effect.

After my process of re-installing the Mycroft software on my Mark I, it is up to this problem again. When the room is quiet, it will blap 3 to 7 times a minute, respond to a command If I give it after the blap, and if I am reading my traffic log right, it is sending room noise samples to the servers all day.
Note that I added the Sleep skill and told Mycroft to go to sleep. By the time i got back that day it was back to blapping and responding to commands if I give them after the sound. Give it some background noise and it behaves correctly.

Anyone have any ideas?

I used the wrong skill name, it is Naptime.

I have tried changing the Listener away from Precise, we’ll see what happens…

Setting the listener to Pocket Sphinx fixes the trigger in a quiet room problem, but the recognition goes down. My temporary work-around will to be setting the listener to Pocket Sphinx when I’m shutting off the other devices, and setting it back to Precise when I’m turning them back on.

Have you tried adjusting the mic level?

Improving the accuracy of wake word detection is always something we want to improve but 3-7 times a minute sounds ridiculous. Given it’s a Mark 1, there must be something else going on as there are hundreds of these units around the world and I wouldn’t want something triggering that often in my home either.

As a reference I just checked my two Mark 1’s and their mic levels are set at 46.

1 Like

I was not aware that was an adjustable setting. I’ll see if I can find that setting and tinker with it. Thanks.

It’s not something that would generally get changed, so I will be interested if it is different.

There are a few ways to do it, a simple terminal based GUI is provided by running alsamixer

Fired up alsamixer, the default capture is 46. I’ve lowered it to 40, which is working with the computer and AC running, I’ll find out in the morning what happens when I bring down the noises. At this point I’m not optimistic.

I’ve gotten the capture level down to 5, this seems to be working to keep the bleeping down. Now the question is how to make the level permanent. If the usual ALSA tools will work, I’m OK, if I need a Pluseaudio tool, I’m stalled for the moment, search engines are not being helpful. Rather than just trying things at random (risky when Pulse is in use) I’m looking for specifics on making settings persist.

I’d think something like:
sudo alsactl store
should work.

Some other ideas here