Neon AI not booting up

Hi all,

on the Mark II, I’ve chosen mycroft ai in settings and after that it seems everything stopped working (at that time I didn’t know all relations between Mycroft - Neon - OVOS). At first loaded but at a next boot-up it stopped - getting now just black screen with a lot of fan noise.

For this reason, I’ve created a bootable USB with latest version of NeonAI, using these instructions: Neon AI OS for the Mark II | Neon AI . Now, when trying to boot it up, again nothing happens (or same), seems like an infinite cycle.

I have Mark II connected to net with an ethernet cabele. When I received it, there’s also a Sandisk USB key, not sure what that one does. Still, I’ve tried booting with and without it. Same results.

Any ideas?

Thank you,

@NeonClary (Neon’s workday hasn’t started yet, I’m just bumping this up to the top of her inbox)

1 Like

This sounds like you got one of the bad batches of SJ-201 daughterboards. If you’re comfortable opening up the Mark 2 and testing if you can power the Pi inside after removing it from the SJ-201 board that will confirm it. Either way, you probably want to reach out to to start the RMA process.

@plur9 Some troubleshooting checks -

  1. Make sure you have only one USB boot drive plugged in to the Mark II, and that you plug power into the Mark II after you plug in the USB.
  2. If you remove all USBs and then plug power into your Mark II, does the fan come on? If not, it’s probably going to need to be returned.
  3. If the fan comes on fine, then the next thing I advise trying is to re-image your boot drive with Neon. Sometimes, especially when imaging with a computer, it doesn’t work perfectly.

One other thing you can check is if the display cable is not loose. This happened to mine as well (two times). You can open it up and reinsert the cable. Or wait 5-10 minutes with power on and check if it responds to voice commands. if it responds, it’s not the daughterboard or boot drive.

1 Like

Thank you for the tips! I’ll be able to give it a try over the weekend or next weekend.

1 Like

Hi @NeonClary,

thank you for suggestions. Here are the results:

  1. Tried with all three options (neon sdd, sandisk usb (not sure what it is), and my own usb), and with eth cable. Same results, can hear the fan, don’t see anything on screen.
  2. Removed everything, can hear the fan.
  3. Created a new USB, following instructions here: Neon AI OS for the Mark II | Neon AI

None of this worked.

My suspicion atm is that Mark II doesn’t boot from bootable USB key, so I have created a new RPI4 USB. I see that my other RPI successfully booted from the USB key but Mark II doesn’t.

I also tried booting up both RPIs with Neon AI USB sticks. They don’t even show up on the network (used nmap). For the NeonAI USB, I did it twice - once without additional settings, once with them (setting wifi, first user, enabling ssh).

I haven’t yet opened the Mark II, this needs to be next step, I guess? Are there any other ideas?

@plur9 We’ve seen SJ-201 boards fail exactly as you describe, and unfortunately there’s nothing to do but replace the board at that point. I recommend you copy-paste your reply into an email to and I’ll start an RMA for you.