Neon AI doesn't go to homescreen after update

This could be a timing issue, however, I just updated Neon AI to the latest release and it boots to the Neon AI screen with the orange logo rather than going to the homescreen.

I can drag down from the top to get the settings screen and it shows the wallpaper behind the settings, however, selecting “<Home” does not show the main desktop with the wallpaper.

After a long while and enough reboots, the homescreen/wallpaper will display.

I believe this to be the device still processing the update, however, once the ‘Neon AI / orange’ screen is displayed, it will respond to commands, display the menu, etc.

Either it should show it is still updating or go to the mainscreen. Some form of ‘still updating…’ should be shown.

2 Likes

Thank you for the feedback, always appreciated! Some follow up questions -
Did you happen to notice if it had announced aloud that Neon was ready before it had the home screen up?
Were you updating to the latest stable release, or a beta?

Thanks!
Clary

Updating to the latest stable version. It had not stated it was done. yet, althought from all appearances it was since the spinner/busy icon (upper right) had stopped spinning for 5+ minutes. Add to that saying ‘Hey Neon’ triggered the ‘listening’ lights, sound, and response and it gave all indications it was done.

Another question. How do you change the wallpaper without saying ‘Hey, Neon, change the wallpaper’?

The upgrade change the wallpapper and the menu for what appeared to be wallpaper settings doesn’t work.

1 Like

Me also similar, took mycroft out of the cupboard ( gave up on it ever working properly) to try it again with new update. Have booted 7+ times and only once showed home screen and active mouse , at about boot 5 think and achieved home network connection and location of Madrid. Been on 7 hours now and no Home Screen, pull down or mouse.

Welcome back @fleetwood thanks for giving it another try!
I’m guessing you haven’t done the “hard” upgrade to Version 2? https://neon.ai/UpgradeGuideV2.0
Can I ask also, are you running on a USB drive, or an SSD drive?

@tiredoftry Swipe left across the middle of your screen to change the wallpaper. The default should not have changed. I just checked, and my menu isn’t working either. I’ll let Daniel know, and ping you back about all of this. I think you have an SSD already, right?

Good quick repl. I am version on 23.12.28 ( she says uptodate). Swiping screen any way does nothing to remove gecko logo. Also realized that my new USB stick would not have my previous data, eg metric, time zone, my name, etc. Maybe a good thing as she started to talk irrelevant garbage previously & hence relegated to cupboard .
Yes, do have ssd but current image downloaded on a new usb stick using raspberry imager (latest).
Probably not relevant but fan started up couple of hours after a ‘shutdown’ so then power got switched off

1 Like

Hate to say it, but I suggest putting the new image onto your SSD and trying booting up with that. It will erase your old data, but sounds like that would be okay with you.

Is that a Neon USB? It doesn’t sound like it’s doing what it should. Usually they are slower, but not to the point of malfunctioning. If I sent it, let me know and I’ll replace it.

The fan coming back on about a half hour after shutdown is a known issue, which unfortunately did not yield to any of the fixes we tried. Since we’re limited on dev time & folks will need to unplug anyway before starting back up, we prioritized other fixes for now.

@NeonClary Swiping left does change the wallpaper, but also caused a new issue. It eventually goes to just the time being displayed with a black background. I am guessing this is the ‘no wallpaper’ option. How do I get back to a wallpaper?

Swiping right doesn’t work and swiping left doesn’t start over at the beginning wallpaper.

@tiredoftry I’m unable to replicate that issue, either on the latest stable or beta releases. I tried both, and the wallpaper cycles right through when I swipe.

Also, although first boot takes a few minutes, it shouldn’t take repeated boots and certainly not more than one to get rid of the splash screen. I did verify that on mine also the system states it is ready about 3 seconds before the splash screen disappears. I’ll put in a note about that to our dev team.

Are you comfortable re-imaging one of your SSD drives? Because unless you’ve customized things, I’m thinking you have a faulty image or an issue with the drive and I’d love to get you back up and running.

I can re-image it to see how it response. FYI, every time I update the OS, it will stay on the ‘orange’ logo screen for a very very long time (hours). In most cases, I get impatient and reboot it, but it still does the same thing until some voice command seems to finish and go to the main screen. Typical ones I try are “what is the”… time, weather, date, etc.

I’ll let you know how the re-image goes tomorrow.

1 Like

New image this morning.

Network connected successfully

Neon stated it was ready
2 minutes later the home screen was displayed
1 minute later it started switching between the home screen and ‘Setup Networking’ where the home screen would display for about 5 seconds, Setup Networking would display for about 30 seconds, and repeat.

Leaving it alone for a while to see if what it will do next.

Gave up after an hour of it flashing back and forth and rebooted. Seems to have resolved the issue.

as suggested by clary put new image onto existing SSD (wiped all previous) instead of usb stick.
now all working all-be-it slowly. do hope that will improve over time but a bit frustrating.
will now get neon to do bootable media onto the replaced USB stick and to see if it retains metric/time zone/name etc
can we have a link to pdf or similar that explains how it works and ‘train’ neon ( not that garbage that came with machine that is of no help in “how to…”)
computers are logic! i have not found anything yet that is logical on how to use neon
and
skill-update.neongecko.com ------url cannot be found!!

Hi @fleetwood I’m sorry about the delayed reply. Now that we’ve got the forum moved over, I am going to be scanning all new posts so should be more responsive even without tagging.
Here is our skills guide - Neon AI Skills Guide | Neon AI is that what you are looking for, or did you have something more technical in mind?

Do you remember where you found the link to http://skill-update.neongecko.com/ ? I will get it fixed.