Need help with mycroft.conf

Hi :slight_smile:

I have an issue with the configuration of the Mycroft Core. It’s only a small problem and won’t affect the development of other skills for me, but I kind of want to get it fixed.

I paired my device, running on Ubuntu Virtual Box and changed the mycroft.conf to my location settings in the /mycroft-core/mycroft/configuration directory. I also added my private API keys for the WeatherAPI and Wolfam Alpha and I changed the temperature settings to “celsius”.

The problem I’m having now is that if I ask Mycroft “What time is it?” it will still tell me the time for the default timezone. Same problem with the weather report - I still get the weather for Lawrence, KS and the temperature is being told in °F instead of °C.

I already tried changing the location of my device in and I also copied the mycroft.conf to the other two locations specified in the documentation without success.

As already said, this is not a big problem, because I already developed a skill which basically doesn’t need these settings but it still bothers my somehow.

1 Like

could you solve your problem and can you describe how you did that?
Otherwise could anyone else help please.
Thanks in advance.

i played with mycroft a bit and i could see that time to times myroft tries to reload its configuration from different locations. Each time it finds one it overrides it (I don’t remember the order). I have stopped pairing my device to the website and now my own configuration is loaded correctly.
You can try this :slight_smile:

[EDIT] I found the load order from the code (mycroft/configuration/ if that may help

DEFAULT_CONFIG = join(dirname(__file__), ‘mycroft.conf’)
SYSTEM_CONFIG = ‘/etc/mycroft/mycroft.conf’
USER_CONFIG = join(expanduser(‘~’), ‘.mycroft/mycroft.conf’)