National Parks Skill not working

Welcome! This is the right Category if you have support questions about the operation or creation of Skills. When requesting support, please be sure to provide;

National Parks Skill
I tried saying “Describe Yellowstone National Park”. Got an error to check my API setting. I seen that my API was NOT set yet again on your website, so I added it. NPS still did not work stating the exact same error, so I chose to get a new API. I set it to the new API on the web page and tried it again. Same error

Logs are also helpful. I don’t know how to attach a gz zipped file to this post

For the logs, try pastebin.

I tried to paste, but you meant something else. I will duckduckgo pastebin and try again.

I need a way to upload a zip file, not copy and paste the logs as they are very long.

you can paste the relevant sections of the logs, as that would be more useful.

Hey TrekJunky,

The easiest method to upload logs is to say “Hey Mycroft, create a support ticket”, but if this doesn’t work or you want to be more specific about the logs you provide you can run the following to upload a single file to termbin:
cat /var/log/mycroft/skills.log | nc 9999
or if you want to upload all logs you can do a slightly longer:
for log in /var/log/mycroft/*.log; do echo "====$log====" | cat - $log | nc 9999; done

The National Parks Skill got updated last week and this shouldn’t have cleared the API key from your settings but it seems to be a likely cause given the timing. I’ll check in with the backend team to see if they can shed any light on this.

I also noticed the NPS dev site has been down so there may be temporary issues connecting with their API.

Thanks. Keep me posted. The last time (A month ago) I tried to say “Hey Mycroft, create a support ticket” it didn’t email me. I will try it again today.