Mycroft snap application does not start on Zorin OS 15.3 after installation

Hello dear Mycroft Team,

I just installed Mycroft on my Zorin OS 15.3 distro. I have updated the system prior, so it is as up-to-date as it gets.

Things I did so far:

  1. First I noticed a the release of Mycroft on the Snapstore (on and installed it.
  2. After the installation was completed I tried to launch Mycroft but nothing happens.
  3. Then I tried “mycroft” in Terminal and I get this response:
    username@ASUS-ZorinOS:~$ mycroft
    /snap/mycroft/1078/bin/mycroft-launch: line 92: mycroft-cli-client: command not found
    Stopping all processes…
    mycroft-skills: no process found
    mycroft-enclosure-client: no process found
    mycroft-speech-client: no process found
    mycroft-audio: no process found
  4. Then I unsinstalled it via the software center of Zorin and then reinstalled it using the command in Terminal “snap install mycroft --beta” … no difference…
  5. There is no process showing up in the System Monitor, so I have no clue if it actually starts to run or doesn’t. Is there a specific process name I should look for?
    Perhaps the installer is still running after the snap “finished installation”?

Please help me find a way to start Mycroft. So far I can’t even manage to connect Mycroft to the online services.

Previously I could run mycroft on this PC by cloning the git, and I had some experience, however at that time it froze more than not.

I don’t believe the snap is an actual release from mycroft itself yet. This was still in progress…

You could use the desktop install instructions from, though, that should get you up and running.

Thank you, but I suspect yo may not have fully explored the docs yourself since it begins with saying:

" Getting Started

There are multiple ways to install Mycroft for Linux.

Snap Package

Mycroft is now available as a Snap package. Providing a simple and secure means of installing Mycroft on a broad range of Linux distributions.

The Snap package is currently considered an Alpha release. Find out more: LINK"

Thank you nonetheless. Sorry if I am being a bit cocky, I will try installing through Git aswell, until then I do consider this topic still open…

PS.: I did in fact read the official Snap documentation prior installing the package.

You got me curious about that snap thing just to know what is happening there. Someone yesterday reported the Wakeword not working (although it wasn’t working on a git install either) and not finding the user conf due to a complete different structure.

I’d just use the git install. :wink: