Mycroft Responding without Wake Word being spoken

So I interesting issue. Mycroft responds at times without the wake word being spoken.
It happens to everyone in the house, the TV, and last night it tried to answer the sound of dishes clinking together when I was washing them.

The Spouse Approval Factor is low considering that Mycroft doesn’t respond to her voice very well, but it responds to mine just fine.

We are using “Hey Mycroft” as the wake word.

1 Like

THX for your thread. Let me tell you: my wifes ‘hey Mycroft’ did not trigger as good as my keyword. This is because of the high’s and deep sound of the the different gender sound. Pub that sounds strange but Alexa and google had the same issues. Here is a thread about it in the community.

Can you tell us what hardware are you running Mycroft on? Is it a mark1 or any kind of own build environment.

Is your mic working, was there a time when is was working better than now?


Hey, thanks for the offer of help.

I’ve been running Mycroft successfully for about a week now. I had a few hiccups along the way but things are pretty stable.
I am running Picroft on a Raspberry Pi 3B+ with a Respeaker 2-mic PiHat.

The mic works well now. One of the hiccups was the mic not working at the start but that’s been resolved.

Check if you’re using precise (ask which listener are you using?) and then ask it to switch listeners to precise if not.

@baconator Sorry to ask but how do I check that and make the switch?

ask mycroft which listener it’s using, then ask it to change listener to precise.

@baconator Just checked using the CLI and it reports that “The Listener is set to Precise.”

The model is primarily based on average north american male voices, due to responders. One option would be to model your own using precise, with “hey mycroft” or a custom word. Another would be to start tracking the wake words that trigger it and seeing if there’s a common thread that you can work to removing. Also possible to switch to pocketsphinx but that’s generally not a good idea.

I’m pretty fortunate it’s working at all and I’m in IT for a living.

Asking me to model my own (I assume wake word) and track non-wake words that wake Mycroft is going to get you:

Seriously though I appreciate the advice but at this point in my learning curve that’s way over my head. Also when a glass clinking against a plate triggers the wake word, I just don’t know how I would remove that…

1 Like

You’d record that noise and use it counter-modeling.
Check out for more, it’s not too bad, honestly. Can be done pretty easily on any modern cpu. 20 samples will get you started, 50 will start it working well, the noises that you know trigger it should get added to the not-wake-word samples to help ensure it doesn’t get triggered.

Well I know that’ll kill any SAF that’s left.
I’m a bit disappointed in the Wake Word portion of Mycroft. Having moved from Snips where the wake word detection was bang-on to this feels like a giant step back.

Pretty much everything else has been great but it’s super annoying when the Wake Word is triggered by random sounds, oh I forgot the best one, it trigger a few times yesterday while it was playing back the news using the ‘latest news skill’

Strange how something so small can cause so many issues

Typically, precise is very accurate. It’s curious you’re having such difficultly. The only other thing I can think of is it hasn’t finished downloading the model and binary. You can see if you restart it in the logs (/var/log/mycroft/voice.log) if it’s loading the wake word via precise or pocketsphinx.

Having moved from Snips where the wake word detection was bang-on to this feels like a giant step back.

Other than Mycroft still being open source and not sold to Sonos, of course :wink:

yes, but I was referring to the functionality. Just tonight 3 times Mycroft ‘triggered’ when I was reading a recipe while we cooked some goodies for a Christmas party tomorrow.
I had 0 false triggers with Snips.


Looks like I am not getting Precise for my Wake Word

2019-12-14 03:45:40.076 | INFO | 872 | mycroft.client.speech.hotword_factory:load_module:312 | Loading “hey mycroft” wake word via precise

2019-12-14 03:45:50.083 | INFO | 872 | mycroft.client.speech.hotword_factory:load_module:338 | precise is taking too long to load

2019-12-14 03:45:50.087 | INFO | 872 | mycroft.client.speech.hotword_factory:load_module:312 | Loading “hey mycroft” wake word via pocketsphinx

2019-12-14 03:45:50.450 | INFO | 872 | mycroft.client.speech.listener:create_wakeup_recognizer:340 | creating stand up word engine

2019-12-14 03:45:50.462 | INFO | 872 | mycroft.client.speech.hotword_factory:load_module:312 | Loading “wake up” wake word via pocketsphinx

2019-12-14 03:45:50.624 | INFO | 872 | mycroft.messagebus.client.client:on_open:67 | Connected

I understand you but I think it just need some time to get better results. The past show us that the wakeword detection worked better and better. Mycroft is still an opensource projekt and need feedback like yours.

The other part is the mic-hardware. Once I used the ReSpeaker 4-mic array and now I changed (cost like 3-times the 4-mic-array) to the ReSpeaker Mic Array v2.0. The results are awesome! The mic-board calculates the “what could be the input” by subtracted the output. The results are really nice.

But I have still some wrong wakeword detections too.

This is almost certainly why. Check what’s in the ~/.mycroft/precise directory?

Here is the contents of the ~/.mycroft/precise directory:

-rw-rw-r-- 1 pi pi 26556 Mar 21 2018 hey-mycroft.pb
-rw-rw-r-- 1 pi pi 132 Mar 21 2018 hey-mycroft.pb.params
-rw-r–r-- 1 pi pi 11540 Sep 27 13:51 hey-mycroft.tar.gz
drwxr-xr-x 5 pi pi 4096 Jun 25 2018 precise-engine
-rw-r–r-- 1 pi pi 51899731 Sep 27 13:45 precise-engine_0.2.0_armv7l.tar.gz

This doesn’t address the issue at hand, but I’d be remiss not to toot my own incredibly boring horn: “Hey Mycroft, install Dismissal” so that you can say “nevermind” when this happens.

(I don’t get a lot of false activations, but I do activate him just to check on him a few times a day, so…)

I presume you’ve rebooted picroft since and it’s still having this issue?