Mycroft Not listening to me


I’m running Mycroft on Ubuntu 18.04.

  • When I run Mycroft manually through the terminal using ./ cli, he only responds when I type a question. And, he only listens when I ask a question which prompts him to ask me for more info.
  • When I run ./start all, i get a lot of logs but nothing happens.
  • When I run the mycroft I downloaded from the software center by clicking the icon, the computer says it’s running and it’ll take a moment before mycroft listens, but nothing happens.

My Log

~~~~ch skill settings: ValueError("invalid literal for int() with base 10: ''",)
Traceback (most recent call last):
~~~~/mycroft-core/mycroft/skills/", line 386, in _poll_skill_settings
~~~~inyamin/mycroft-core/mycroft/skills/", line 364, in update_remote
    skills_settings = self._request_my_settings(hashed_meta)
~~~~/mycroft-core/mycroft/skills/", line 486, in _request_my_settings
    self._type_cast(skill_settings, to_platform='core')
~~~~e/binyamin/mycroft-core/mycroft/skills/", line 464, in _type_cast
    sections[i]['fields'][j]['value'] = int(value)
ValueError: invalid literal for int() with base 10: '

Hi there @b3u,
When you say you installed this from the Software Center, do you mean that you installed a PPA and a package? If so that package is very out of date. You might want to try the Mycroft for Linux instructions instead.

I used those instructions already:

In terms of the software center, I used the gui.

This Python error is usually seen when something that is a float is being treated as an integer. Have you installed any Skills recently and configured them on Could it be that there is an integer or float in the Skill Settings that is not working properly?

I have installed skills from, but the issues existed previously.

How would I fix this issue?

In order to diagnose this further, I would need to see your skills.log. Are you able to paste it or upload it?

Where would I find my skills.log?

Sure, we have some documentation at;

I don’t seem to have the folder scripts/logs. Searching for the folder returns nothing, even when mycroft is running. :confused:

As a side note, if I have phrases I would like to be integrated into Mycroft (Such as “What is <topic>” equals “Search internet for <topic>” or recognize “I/Me” as b3u not Mycroft, how can I suggest they be integrated?)

Ah, apologies, our documentation is out of date, totally my fault.

Do you have logs in /var/log/mycroft/?

We always welcome Skill Suggestions, and they can be submitted here;

1 Like

Thank you. I don’t have a var folder. When I search for “log”, Nautilus (or folder viewer) returns a folder in .git, a folder in /mimic/.git and a bunch of .dialog files.

If you open a new terminal and type:

ls -las /var/log/mycroft

what do you see?

I see files. I’ll upload the skills.log presently

Here’s a gist of the skills.log:


just to make it clear to me: Mycroft doesn’t react when you say Hi Mycroft? But it works ok when you type things?

If that’s the case it sounds a bit like the wake word isn’t detected correctly. I would like to see the voice.log to be able to debug further.


I’ve updated the gist. At the bottom, click on voice.log > view raw

From the log it seems like the wake word was triggered. and heard you say “minecraft play spotify”

When you say “Hey mycroft” do you hear the ding that indicates that mycroft is listening?

No. I don’t hear a ding either when I type “Hey Mycroft”

Now it listens occasionally to “Hey Mycroft”. Is it possible that its because my computer is just slow?