Mycroft Mark II missing files

I received my Mycroft Mark II after a long wait as everyone else. Was really excited when it arrived but since it was close to Christmas, I decided to wait to give it a try. Today, I was excited to give the device a try. However, after a quick setup process that went smoothly, my excitement soon turned to disappointment. All I have is a clock that tells me it does not understand. So, thinking I was doing something wrong, I took to the documentation. The site says I can have skills installed but every skill I try to install will not work and I am told that Mycroft does not understand. Thinking I am still doing something wrong, I come to the forums to get some help. Now, I am even more disappointed. Seems as though I do have a clock that does not do anything. I guess I got the weather read to me… So that is something… I knew there would growing pains with a new device such as this but I guess I was not expecting this low of functionality. Before I put this on the shelf of wasted money and electronics, can someone tell me there is a way to make it work? I was sold a private Alexa but in the spirit of Charlie Brown, “I got a rock.”

3 Likes

You are not doing it wrong. They swapped out the OS and nerfed it before sending us our units. You do have options but each has its own issues:

  1. You can wait until skills get ported to the new OS. Unfortunately, many devs said they are not putting in the work for this since they are just community users like us and don’t want to maintain 2 skills.

  2. You can load another OS(basically rollback to the previous version of the OS). However, you need to take the time to do it and ross your fingers that you did it correctly otherwise, you have to follow the same steps you just failed on to load the original OS back and hope you did THAT correctly.

  3. You can load an OS from Neon/OVOS - basically 3rd party OSes made to do what Mycroft should have been made to do to begin with minus being able to stream music from a provider of your choice.

  4. As you have mentioned, you can toss it on the shelf for a bit or ask for a refund.

I have filed a complaint with the FTC for bait and switch tactics since the product we received was not the product we were told we are purchasing and we were not told of the change and given an opportunity to get a refund. My complaint # is 154923134.

I encourage anyone in the US to file a complaint as I did. You can do so by clicking here.

2 Likes

Thanks. Appreciate the info and glad to know I was not doing something wrong. Will look over the options presented and see what might make sense. Really wish it would have worked out of the box and was what I was expecting…

Silly question perhaps…

Have any of these struggles (and perhaps successes) been translated to updated documentation?
I’m waiting for my Mark2s to arrive, and now know that it’ll be a bit of a project to get them to do useful things.
I also know I’ll be documenting the heck out of getting them to work… For future generations.

The master branch of Dinkum hasn’t seen a commit in a month and a half. It appears there’s a tiny bit of work going on if you look at active branches.

The documentation I’ve found looks to similarly be relatively low activity (note that it is the holiday season). I would hope that a sufficiently valuable PR would be merged? It looks like there is a history of accepting PRs, though I haven’t personally tried.

The 2 devs involved in dinkum are gone and I believe they are hiring replacements(I could be wrong on the hiring replacements point but am looking at their job postings.).

@gez-mycroft @michael-mycroft
Oh man, fancy digital clock and weather app atm, any update on when we can install new skills?