Mycroft Mark II missing files

I just got my Mark II but it is unable to do most of what is in the documentation on the website that I was led to from the included paper. I cannot add skills, many skills do not work, and it mostly just tells me it can’t understand.
After some fumbling I managed to SSH into the Mycroft only to find that basically nothing listed in the website documents I could find are on the mycroft.

mycroft-config get did not work, because there was no configuration file in any of the four places listed on this page:

Adding skills didn’t work, because none of the commands here worked/existed:

I feel like I got a unit that wasn’t really programmed. Is there any kind of factory reset to ensure I actually got everything? There’s a usb drive stuck in the back out of the box, is that where the OS is stored?


Hi there,

Great to hear you got your Mark II!

The production Mark II ships with a custom version of Mycroft Core, known as “Dinkum”. We focused on reliability, which required reworking some of the skill API. Not all skills in the marketplace are compatible yet, but the device does ship with these skills pre-installed:

  • Alarm
  • Date and Time
  • Home Assistant
  • Homescreen
  • IP Address
  • News
  • Jukebox (local music from a USB drive)
  • Radio (online music)
  • Wikipedia/DuckDuckGo/WolframAlpha
  • Timer
  • Volume
  • Weather

We have some new posts coming to provide a deeper explanation on the new software, and we’re working on specific documentation for this version of Mycroft at:

Keen to hear how you find your new Mark II and certainly shout out if you have any other questions.

This information should have been communicated to recipients with the device or by other means. I’ve wasted two days trying to get mine to work, only to find this out.


Same experience here – it felt like I purchased a product that had a corrupt or partial software install.

To compound this, the on-line docs either don’t apply or have broken links.

It’s been very frustrating, and has largely convinced me not to purchase a second one.

Please, help change my mind.


Not being able to install skills makes the device mostly a novelty. Any ETA on when CLI or Marketplace skill install will be enabled?


I’ve been unable to install many other skills (for example “List Manager”, “Theia IDE”) through the Mycroft interface. I think I’ve installed them via and SSH connection, but the absence of documentation for Mycroft II and the absence of the utilities that are mentioned in the docs leaves me unable to activate to use the skills.

Lots of stuff seems to be missing or broken (ie. no pre-installed skill to safely shutdown the device, no pointer to the Mycroft II-specific docs showing how to get to the on-screen menu, etc).

It feels like I’ve gotten a crippled device, with less functionality than if I had made it a DIY hardware project and used the available software – at a lower cost.

Notes on the documentation:

1 Like

Mostly a paperweight, IMHO.

1 Like

The Mycroft II docs say:

Please note, at this time the Mark II does not include a Configuration Manager utility. Any changes must be made directly to your mycroft.conf

with a link to docs about mycroft.conf … that directs people to use the configuration manger utility if possible.

If I were to edit one of the mycroft.conf files (at my own peril, with neither a safety net nor a json syntax checker), what’s the recommended way from the CLI, without mycroft-config, to tell dbus to reload the new config?

We have a more complete post coming soon, but the short version is that the Mark II ships with the “retail” version of the software. This version does not have certain features that we found problematic to get right for the non-technical user.

Rest assured, we will soon be releasing images that allow you make use of the hardware with any version of Mycroft. This should be within days, not months.

We are also working on making the documentation more clear, for all the versions.

1 Like

Thank you much appreciated!

I also went thru not being able to install additional skills. This leaves the device in a pretty un-useful state. Wish you guys would have warned people. After trying a voice install to no avail, I then spent hours looking for a “mycroft-msm” command, that it apparently doesn’t have.


Is the Dinkum API going to be modified or extended to support the existing marketplace apps or are we on our own/starting over?

Was really hoping to install some of the existing skills on day one.


This is very frustrating. I was hoping to start phasing out the Alexa device as soon as my Mark II arrived but this “retail” version of the software is essentially useless. I don’t think anyone who pre-ordered one of these was expecting to get a 100% reliable box that can do a handful of simple tasks.

The lack of communication about this is surprising, I am sure there was pressure to get the devices shipped but I would have preferred to wait for a fully functional OS than to get a box that mocks me with it’s limited capabilities.


It was particularly surprising for a free and open source project to arrive with significant design changes which don’t seem to have been developed in public, which no one in the community seems to have known about, and for which the source code still doesn’t seem to have been published anywhere. Similarly, the devices seem to have been distributed without instructions or scripts for replacing the installed OS with modified versions.

The "Dinkum” redesign may well be for the better: the explanation for the changes in README files I’ve found while SSH’ed into the device does make sense. But it would be more reassuring even just to be able to find those README files in a Git repository somewhere, or to have a clear place to report bugs (e.g. Mark II: bad news url in web UI breaks `dinkum-skills.service` · Issue #96 · MycroftAI/hardware-mycroft-mark-II · GitHub).

I hope more communication is indeed coming “within days, not months” (given that it’s now been a week).


I was expecting – and would be very happy with – an OS that is not 100% fully functional, but which is open, allowing the use of skills that already exist for other Mycroft versions, and which is customizable and well documented.


Hi all,

We definitely did not have the documentation up to scratch before launch. It has been a non-stop sprint to get this Mark II out for longer than I can even think about. We’ve been punching out new docs quickly to help you get up to speed, and I’m very keen to hear about anything missing or that just needs more detail:

We’re also in the process of getting all the repos for the Mark II public along with more information on what Dinkum is, why we went that route. There are also additional images to use your Mark II hardware in whatever way you choose. There’s one that runs classic mycroft-core, and also a bare bones DIY image that contains only the Mark II hardware drivers on a Raspberry Pi OS base - everything required to utilize the Mark II as your own voice development platform.

Finally we are very keen to hear what features or improvements you want to see for the Mark II to inform our future roadmap. To help with this I’ve created a new forum category and brought back the voting module. If you have ideas please add them here, or vote them up if someone has already posted about it.


Thanks for the update, I am glad to hear there are alternative images to use.

Will your team be producing written guides or a video for the end-to-end process of taking our Mark 2’s and putting regular mycroft-core on it?

I think many us who ordered these are newcomers to Mycroft in general. I know i am

1 Like

seconded, am in the exact same situation.

1 Like

Hey, working on the documentation now actually. But overall it’s a simple as flashing the image you want to a USB, plugging it in, and booting the Mark II.

The two exceptions I can think of is

  1. WiFi setup because the solution we’re using for that is tied into our update management system. On the classic mycroft-core image wifi can be set by either using the Raspberry Pi imager that bakes your wifi creds in as it burns the image, or manually setting those on the filesystem.
  2. There is no automatic updates in these images as they don’t use the Pantacor container system that comes on the default “Dinkum” retail image.

After that the Pairing Skill will prompt you to add it to your account just like the Dinkum image.

It should also be noted that the classic mycroft-core experience won’t be as polished as the retail version Dinkum. There are bugs and quirks, and that’s a pretty big reason for why we made Dinkum in the first place.