Mycroft listening too long

I’m using the Mycroft extension for the Gnome desktop and Mycroft is taking a long time to stop listening for commands. It listens for a total of exactly 20 seconds before it stops listening. I assume 20 seconds is a built-in time limit or something, but why is it listening for the full 20 seconds and not figuring out that I’ve stopped talking after a short ~2 second command?

i “fixed” this problem by turning down mic volume in gnome-audio-settings, maybe it works for you too

Works for me too, thanks! I turned it down to “Unamplified” and Mycroft now responds in a normal amount of time.