Mycroft just says "Sorry, I didn't catch that. Please rephrase your request." for everything

I have just installed Mycroft on my laptop. Also I have paired it with the code. However whenever I ask it bout something, it always says “Sorry, I didn’t catch that. Please rephrase your request.”. Mycroft is able to hear the wake word. Please suggest me what to do next.

Sounds like the intent parser isn’t installed/working properly.

Do you have access to the log files? Can you share the output with us?

I don’t know what happened. I just ran Mycroft with superuser permission and everything is now working just fine. By the way thanks.

Thanks @Kishor_Sonawane - when you say you ran Mycroft with su, which commands exactly did you use? I’m tracking a very similar issue with another user.
Best, Kathy

sudo ./ debug

I was in the Mycroft core directory.
It then changed the ownership of all the files I guess.

I had that too on some occasions. A phrase which previously worked and then next turn just the error. Reboot the RPI worked for me.

I’ve done an update since then. Haven’t used it much as I’m on vacation currently :wink: