Mycroft Installation error

Following is the error which I’ve not been able to resolve while installing Mycroft on Arch linux. I even tried this on an Ubuntu virtual machine and had the same error

Collecting git+ (from -r requirements/tests.txt (line 8))
    Cloning (to revision v1.2.7.dev1) to /tmp/pip-req-build-j_m3zgch
    Running command git clone -q /tmp/pip-req-build-j_m3zgch
    Running command git checkout -q 4e73cabf1b2445b3c1ab6b3aed14424d32d140ac
       ERROR: Command errored out with exit status 1:
        command: /home/wolf/mycroft-core/.venv/bin/python -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-req-build-j_m3zgch/set'"'"'; __file__='"'"'/tmp/pip-req-build-j_m3zgch/'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'
    "'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-req-build-j_m3zgch/pip-egg-i
            cwd: /tmp/pip-req-build-j_m3zgch/                                                                                                      
       Complete output (3 lines):                                                                                                                  
       /home/wolf/mycroft-core/.venv/lib/python3.9/site-packages/setuptools/ UserWarning: Usage of dash-separated 'upload-dir' will no
    t be supported in future versions. Please use the underscore name 'upload_dir' instead                                                          
       error in behave setup command: use_2to3 is invalid.                                                                                         
    ERROR: Command errored out with exit status 1: python egg_info Check the logs for full command output.

Hi Karan,

It’s really hard to install Mycroft using python. Instead you can try with ./

in general: you’re better served with py3.7/3.8 (just use pyenv,… with a py3.x shim)

but why is use_2to3 been used? py2 → py3

I guess, he did not checked out the latest “dev” branch as I believe @gez-mycroft fixed it with;

However regardless of that, that dependency is for the test setup and is not needed if you just want to run mycroft.

1 Like

Yeah it’s from upstream packages - behave and cucumber. The fixes have been adopted upstream, so we should be able to switch back to the official versions shortly.

1 Like