Mycroft II arrived - problems with wifi

Following this guide downloading the image from google drive (really?!) I’ve ended up at with a network cable. There was no initial Mycroft Wifi access point. If I manually choose a Wifi network, the process never finished. For now, I’ve ended up in “you have to choose a cable connection to have a proper functional Mycroft II”. Any other hints for solving my cable problem? eg. How to enable the wifi chip on the raspi without raspi-config or similar tools? Because that is my suggestion for my problem.

Hi luckow, sorry to hear you’re having trouble with the Wifi.

Can you confirm that no “Mycroft” network has been created, even after a reboot of the device?

To verify that it’s not a hardware issue it would you be able to download a copy of Raspberry Pi OS, or some other standard OS for the Pi’s, and make sure that you can get the wifi setup on that.

Assuming it’s not a hardware issue, it would be good if we could try to replicate your setup as closely as possible. What is the secondary device you are using to setup wifi? Eg what type of phone or computer are you using? Have you tried another device?

In regard to the Google Drive download, this was a fallback when we had some trouble with our downloads server but that has been resolved so I’ve switched it back. The downloaded images will be the same though.

Oh one other thing just occurred to me given you are now using a network cable. Based on that phrasing it sounds like you didn’t have a cable plugged in previously is that right?

I ask because the wifi setup process won’t launch while there is an active network connection.

done the lot of work of printing and combining all parts i got stuck at the same problem with wifi!
No access-point to connect with. The only possibility was, to connect with cable and initiate the pairing.
I tried this with three different images . Last was 2021004-06 stable. Always the same behaviour. I’m not very happy with this, because the possibility of use is very small without wifi.
It seems that there is something wrong in the images.
Wireless setting is not possible. The process is without consequence.
Please analyse the problem for all other with the same failure.

1 Like

As a check, could you disconnect the screen and see if that makes the wifi accespoint visible at a fresh boot?

Hi @gez-mycroft sorry to be late in replying. Yes: I can confirm that no (!) “Mycroft” network has been created. Tested it with different devices & OS. Nothing. Nada. A reboot was one of my first attempts at a solution. I have known computer problems since the mid-90s and most of the time a simple reboot solves the computer voodoo.

I haven’t tried booting the Pi with Raspian or anything like that. But I don’t think it’s a hardware problem. The mycroft pi-image has some limitations with networks. It is possible to install helper tools. But I don’t know what the expectation is for the mycroft image. I guess: you (-> I) - as an end user - should not get deeply involved in the network stuff. And that’s fine. But not having a “first contact” through a “mycroft” network is a problem aka bug.

Later on I’ve plugged a cable to the pi and that was the moment I was able to pair it with my mycroft account. (no wifi at all)

FYI: I have tried different hardware settings. Disconnecting the screen, connecting a monitor, connecting a keyboard, ssh into it, sd-card instead of usb-stick. Just saying :slight_smile:

If you don’t have this phenomenon, what should I do next to help investigate this issue?

I had a problem running Mycroft on a Raspberry Pi: I installed the latest version of Picroft image, which had some issues, one being ‘no wifi’

to solve this, I updated the file /etc/wpa_supplicant/wpa_supplicant.conf
to look like this:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


reboot to restart wifi, and (miracle, oh miracle), wifi connection is made and operational.

1 Like

Hey, apologies for the radio silence - is your Mark II still showing this behaviour?

We haven’t been able to work out what might be happening so wondering if you could get us some more information from your system?

First is a short list of the network manager connections:

  1. Plug in via ethernet and get paired
  2. Add an SSH key to that device in your account
  3. SSH into the awconnect container:
ssh -p 8222 awconnect@$IPADDRESS
  1. Run the following command:
nmcli c

and post that here or email us at

Second, if you’re happy to temporarily share your device logs with us it would also be great if you could
1.login to the main mycroft container:

ssh -p 8222 mycroft@$IPADDRESS
  1. Get your device-id and send that to us:
sudo cat /pantavisor/device-id
  1. Shutdown the device and plug the usb into a computer
  2. In the pvboot partition, edit cmdline.txt
    change the final



This will push your device logs to our backend, so we then need to replicate the issue, presumably:

  1. shutdown the device
  2. remove the ethernet cable
  3. plug the device back in and see if the mycroft wifi AP has been created
  4. wait at least 3-5 minutes after it’s booted to ensure it’s definitely not showing up
  5. plug in the ethernet cable to connect to the net and have the logs uploaded.
  6. run nmcli c again to see if anything has changed there.

You can then change the ph_log.push value back to 0.

Sorry for being late.
Latest mark-ii-stable image - same behaviour.
I followed your list and here is the output of

nmcli c

Wired connection 1 38472afd-3cb6-3d13-bdc0-d089f09d2865 ethernet eth0

lxcbr0 431dbaaa-2729-4b11-8ec5-3106e01cd05e bridge l

Next is to share the logs.
Fun fact. Today I installed the Picroft image and there is no problem with Wifi. So the hardware seems to work.

Hey, thanks for trying it again, and for verifying the hardware with Picroft.

Would really love to get a copy of the logs. We’ve only had a couple of reports of this type of behaviour but 1 is too many!

1 Like

Quick question: did you receive the mail with the device ID and the logfile via ph_log.push=1?
I followed your instructions to set mycroft to the status of sending the log, but have no idea if everything worked well. Best regards from Berlin, Germany

Hey I haven’t seen any email come in via is this where you sent it?

Yes. Sent 15.07.21, 20:55 (UTC +2) delivered to
“details”: {
“server”: {
“host”: “”,
“ip”: “”,
“port”: 25
“response”: “OK 1626375309 t6si8733482wrp.328 - gsmtp”

Hey there,

I have a similar problem, with my Development Kit.
During the setup no mycroft wifi is setup.
I’ve used the image: MarkII_arm-rpi64_Prod_012-stable_2021-08-19.

Has the reason for this behavior meanwile been found?

Many thanks in advance.