Mycroft II - account connection

Mycroft II - can’t connect to account, but signed into website.

Going to need a lot more info than this to help.

Hey there, do you mean your Mark II Dev Kit?

Is this the first time you’re starting the device, or is it a device you’ve previously paired?

I built the DevKit and it was online for 30 +/- days. Pleased with its functionality and performance overall. The 1st of April, I unplugged Mycroft II as was traveling cross country for two (2) months to visit my granddaughter. It ended up being three and 1/2 months. Finally, yesterday, I plugged in the power to Mycroft. After two (2) or three (3) reboots, it connected on line. Checking out the current version, it said there was a newer system version available. Tried to update several times without success, so I removed the SD card and wrote the image with my desktop. After reinstalling the SD card, it took several attempts to get my home internet connection active on Mycroft. It wouldn’t list my home network in the available networks. Swiped across the display to highlight wireless; refreshed and selected home network (didn’t enter a password). Then was prompted to GoTo and create an account, no code for pairing and no other options. Tried several times, but no way/option to connect to my existing account.

Thanks for the extra info.

From your description, it sounds like after you reflashed the image it never reconnected to the internet is that right? If so then the pairing and other processes would never start as they also need an internet connection.

What’s the filename of the image that you flashed to your device?

Can I confirm that your home wifi network doesn’t use a hidden SSID? These aren’t yet supported. If you can share some extra details of your home wifi setup that would help us to figure out what might be wrong. You can also email your answers to rather than posting them publicly.

What type of authentication does your wifi use? WEP/WPA/WPA2/WPA3/other?
How far from your wifi access point is your device?
Do you have MAC filtering or any other “non-standard” features enabled for your home network? Anything that you would consider different to an “out of the box” configuration?

If you’re happy to help us dig into this further, we’d love to get more detailed information and logs from the device but it will require an ethernet cable.

First is a short list of the network manager connections:

  1. Plug in via ethernet and get paired
  2. Add an SSH key to that device in your account
  3. SSH into the awconnect container:
ssh -p 8222 awconnect@$IPADDRESS
  1. Run the following command:
nmcli c

and post that here or email us at

Second, if you’re happy to temporarily share your device logs with us it would also be great if you could
1.login to the main mycroft container:

ssh -p 8222 mycroft@$IPADDRESS
  1. Get your device-id and send that to us:
sudo cat /pantavisor/device-id
  1. Shutdown the device and plug the usb into a computer
  2. In the pvboot partition, edit cmdline.txt
    change the final



This will push your device logs to our backend, so we then need to replicate the issue, presumably:

  1. shutdown the device
  2. remove the ethernet cable
  3. plug the device back in and see if the mycroft wifi AP has been created
  4. wait at least 3-5 minutes after it’s booted to ensure it’s definitely not showing up
  5. plug in the ethernet cable to connect to the net and have the logs uploaded.
  6. run nmcli c again to see if anything has changed there.

You can then change the ph_log.push value back to 0.