Mycroft GUI on RPi4

Hi, everyone!

My idea is to recreate something like the Mycroft Mark 2.
I use a Raspberry Pi 4 with Picroft Image installed on it and a 3.5 inch LCD display for graphic output. Mycroft-Core is basically installed and works fine.

Now it’s about building a GUI and I want to use Mycroft GUI Mycroft Gui for it. So first I installed KDE Plasma on the Raspberry and then I installed Mycroft-gui. Everything worked fine, but unfortunately, I get an error message when I run the Mycroft GUI.

Unfortunately, I haven’t found any other post describing this problem, so I would have these questions:

  1. Is it basically possible to use Mycroft-Gui with Picroft on a raspberry?
  2. Does the procedure basically work that I expand Picroft with KDE Plasma and then install Mycroft GUI on it? Or do I have to use KDE NEON Image, for example?
  3. What does this error message mean when running Mycroft GUI?:

Failed to create wl_display (No such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin “wayland” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, xcb.


Thank you!

1 Like

Mycroft-GUI requires newer Qt libraries than available on Picroft, It requires at minimum a distribution running Debian Bullseye

About the error above:

  1. How are you launching the Mycroft-GUI application, are you launching it inside a X11 desktop session or a wayland session ?

  2. Are you trying to launch Mycroft-GUI directly from tty ? if so you need to export the QT_QPA_PLATFORM environment variable to either wayland or eglfs depending on what compositor background you want to use

  3. If you are looking to mimic the mark-2 then you also need to build and install plasma-nano Plasma / Plasma Nano · GitLab instead of the entire plasma desktop and additionally also install GitHub - MycroftAI/mycroft-gui-mark-2 with additional config files copied to /etc/xdg which you can find at mycroft-devices/overlays/mark2/etc/xdg at master · MycroftAI/mycroft-devices · GitHub

  4. If you instead want to skip developing your own image and just find a running image for the Raspberry PI 4 which creates a smart speaker environment similar to the mark-2 based on Buildroot or Ubuntu focal you can look at the OpenVoiceOS project, we do post development images on the matrix openvoiceos development channel

Hi everyone!

I have some trouble installing Mycroft GUI on my RPi 4 as well.

I am running a Rapsberry Pi 4 Model B with Raspbian (based on Debian Bullseye). When I cloned into the Mycroft GUI repo and ran bash I had to choose option “5) Others” for distribution, which means I need to install Qt5 manually.

I then tried to use the offline installer for Qt5 version 5.15 (link here) but ran into some error during installation. Here is the error message:

ERROR: The OpenGL functionality tests failed!
You might need to modify the include and library search paths by editing QMAKE_INCDIR_OPENGL[_ES2],
QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your platform.

My question is what is the standard way of installing Mycroft GUI on RPi4? Is it even possible?

Thanks in advance!

do not use the offline installer, you need to install Qt packages from your distribution packaging

sudo apt-get install -y git-core g++ cmake extra-cmake-modules gettext pkg-config qml-module-qtwebengine pkg-kde-tools qtbase5-dev qtdeclarative5-dev libkf5kio-dev libqt5websockets5-dev libkf5i18n-dev libkf5notifications-dev libkf5plasma-dev libqt5webview5-dev qtmultimedia5-dev qml-module-qtmultimedia

Thanks! I tried this command but it says

E: Unable to locate package qml-module-qtwebengine

and similarly for libqt5webview5-dev and qml-module-qtmultimedia. What can I do to fix this?

should ask in the distro forum what the package name is called, I am sure they would have the packages but not sure of the naming

Thank you! I had a look at my distro and apparently the Raspberry Pi OS on the RPi 4 is 32-bit, while some packages like qml-module-qtwebengine only supports arm64 architecture. I tried to install Ubuntu 20 but it’s too slow on the RPi 4.

I’m not sure if it’s even possible to run Mycroft GUI on a Raspberry Pi considering the components require Ubuntu 20+ Is there some alternative way to build a simple GUI for Mycroft?

if you want a dedicated diy smart speaker type setup you can look at the OpenVoiceOS project, it has images specifically for the rpi4, development images are generally posted on the matrix development channel You're invited to talk on Matrix, if you want a full OS + mycroft on the RPI4 you can also checkout Plasma Bigscreen its a smart tv type interface, images for that can be found on Release KDE-Bigscreen 20211220 · manjaro-arm/rpi4-images (

1 Like

@yumium @simi If you guys want a simple GUI thats fully customizable, you can go ahead and clone my repo. It only requires a browser, npm, and works out of the box.
Let me know how it goes for you if you do use it.

Also if you feel like contributing, PR’s are always welcome ^^


have a look at my post or directly at the guide that I posted on my wiki

It says that I did it on a RP3 but in the meantime my Mark2 clone is running on a RP4

Have fun - Guhl

@AIIX @Vangrel @guhl Thank you all! Will try them out. In the meantime I found the python module pywebio to be a very simple way to set up a GUI for Mycroft, though it might struggle to build something too complicated.

why don’t you install rpi OS 64 bit?