Mycroft for linux


A first time user here.I am trying Mycroft for linux- ubuntu 18.04. I have cloned the repo and run the file.After that I am trying-

./ cli

I am getting the error -
12:01:58.029 - mycroft.configuration.config:load_local:129 - DEBUG - Configuration ‘/var/tmp/mycroft_web_cache.json’ not found
12:01:58.101 - mycroft.configuration.config:load_local:129 - DEBUG - Configuration ‘/etc/mycroft/mycroft.conf’ not found

Is there a way to create these files manually?

Hi there @SWAPAN_JAIN, great to have you here and welcome.
It’s possible to create these files manually, however I would recommend running ./ again (without rebuilding mimic) - as the script will try and create them again. Take a note while ./ is running to see if there are any errors while it is running.

Kind regards,

How do I run the shell file without rebuilding mimic?

When you run ./, the command line will ask you whether you want to rebuild mimic or not - it detects whether mimic has already been compiled.

I tried running the without rebuilding the mimic but I have the same error.
Also it shows connection refused.

Also after running, I can’t find mycroft_web_cache.json file anywhere in mycroft local repo. Need help.

@SWAPAN_JAIN - could you send an email to That will open a ticket on our end and we can start doing some troubleshooting.


@Darren-Mycroft no need for that,It was a mistake from my side.i couldn’t hear the registration code earlier.

1 Like

Great! Glad to know the issue resolved itself!

Don’t hesitate to reach back out if you need any other help.


1 Like