MyCroft do not answer the questions (What time is it)

Ubuntu 16.04.2
Pairing completed

How can I enable logs to terminal? (to see why the skills are not executed correctly)

“Hey Mycroft” works fine. No response to any standard question. (Just followed the Documentation - Mycroft AI) - Until “Hey Mycroft, what time is it?”
Where do I find deeper information to find the errors/logs? (or how can I enable the services to show the results in terminal?

Thanks for your ideas and help :wink:


First of all, I want to answer your question on how to show logs in terminal:

  • Start the services via ./ start or in separate terminal windows
  • Type screen -list to see all running services
  • Type screen -r <service name> to open the screen (e.g.: screen -r 2051.mycroft-cli--quiet to open the cli interface service)
  • In the CLI Interface, you can either talk to Mycroft or type your commands and it will reply and output the logs.

That said… after installing the Mycroft-core on Ubuntu myself just now, I am also facing the same problem as you are.
After pairing the device with Home, I tried to invoke some sample skills like “What time is it?” via CLI and voice, but neither worked. Weird thing is that I already installed Mycroft-core on another VirtualBox a week ago and back then it worked.

I also made a screenshot of the logs incl. my input in the CLI service.

The old version of the Mycroft-core didn’t have this CLI interface either, so maybe the new version has some issues?

1 Like

Thanks for your fast response. On my screenshot you see that the speech is recognized correctly but the skill is not executed. Here I got the same issue. May be the WolframAlpha Skilll API has changed…