Mycroft-core without root


I want to run mycroft-core without root, but the script requires root for a few steps (installing dependencies and some directory creation).

I’ve changed the script wherever necessary (mainly changed directories to $HOME) for what I can tell, and have manually installed the dependencies for debian (found in the function debian_install in

However, when I run ./, Mycroft just keeps telling me “Please wait a moment as I finish booting up”.
The microphone looks to register and I can trigger the “Hey Mycroft”, but that’s when I get the booting up reply.

Anything else I should keep in mind?

You can see the changes I’ve made in these two commits:
dont install dependencies
use home directory instead of root

Additionally, I’ve disabled home by blacklisting as per:
“skills”: {
“blacklisted_skills”: [

edit: post got flagged as spam. My apologies if my behaviour indicated as such.

Change this setting as well

Thanks! I tried with this now, and it seems like it maybe worked?

Mycroft doesn’t say “waiting for boot…” anymore. However, it can’t understand what I’m saying although “Hey Mycroft” triggers 99% of the time. I tried “Tell me a joke” and “Make me laugh” many times.

What’s default skill which is the easiest thing to pronounce, or a way to test that skills work?

Additionally it might be relevant that there are no messages in the Log Output window after

Establishing Mycroft Messagebus connection...
Connected to Messagebus!

Are the logs being created at your adjusted location? If yes, anything strange in one of them?

Here are all the logs in /home/user/var/log/mycroft/

… limited to 2 links due to being new user

The only weird one I see is in audio.log, but since its loading vlc after I’m not sure if it matters:

2021-05-13 10:16:11.981 | ERROR    |  5839 | audioservice_mplayer:<module>:20 | install py_mplayer with pip install git+
2021-05-13 10:16:11.981 | ERROR    |  5839 | | Failed to import module mplayer

ModuleNotFoundError(“No module named ‘py_mplayer’”)

Edit: Post got flagged as spam, perhaps because I tried posting too many links to log files. My apologies, I hope my post may remain.

… links