Mycroft Chat a.k.a. Mattermost for Mycroft - Skill testing and feedback

Mycroft Chat

Monitor Mattermost for Mycroft a.k.a. and find out if you have been mentioned or if there are unread messages. Messages can be read by Mycroft as well.

How to install skill ‘Mattermost for Mycroft’

  • Install Mycroft Chat / Mattermost for Mycroft by …

    • SSH into your Mycroft device and type
      `mycroft-msm install
    • There are dependencies in form of some Python packages which are listed in requirements.txt. They should be automatically installed by mycroft-msm, if not run mycroft-pip install ... for each line of requirements.txt.
  • Mycroft Chat / Mattermost for Mycroft configuration

    • You need an valid account for Type in your login information at under section ‘Mattermost for Mycroft’. Use your email as login-id.
      WARNING: your password will be stored in clear text in your local settings.json
    • Your Username is most likely different from your login-id and must be typed exactly as shown at -> Account settings -> General
    • If you have a personal access token (you must file a token-request to the admins of you can use that instead of login-id/password.
      NOTE: Username is still required when using a token.

NOTE: for unknown reasons sometimes a restart of mycroft-skill service (or reboot of your Mycroft device) is necessary to reflect configuration change…

How to test Mycroft Chat / Mattermost for Mycroft

  • Configure the Skill Settings in
  • Speak Hey Mycroft, are there unread messages on Mycroft Chat?
  • Mycroft should answer something like there are 3 unread messages on Mycroft Chat
    (this might take a few seconds as the skill must retrieve your channel subscriptions and check for unread messages)

Try all intents:

  • “Are there unread messages on Mycroft Chat”
  • “Name Mycroft Chat channels with unread messages”
  • “Read messages for channel {name}”
  • “Read all unread messages”
  • “Begin monitoring of Mycroft Chat” - this activates a scheduler that checks every 10 minutes (default) for unread messages and mentions. If you have enabled ‘Notify on updates’ (disabled by default) Mycroft will announce new unread messages. Defaults can be changed in the skills configuration at
  • “End monitoring of Mycroft Chat”

Mycroft should have an answer to all intents.

Where feedback on Mycroft Chat / Mattermost for Mycroft skill should be directed a

Please give feedback on this skill through Issues on GitHub, via email or via Mycroft Chat.


I have tested this super skill you created. It works perfectly for me.

I have made a smaller change to let it save setting for monitoring during restart/reboot device and added Danish language and small change to

I made a PR against your repo so you can merge it if you like it :slight_smile:

1 Like

Attention to all testers of this skill - the Github repository has been renamed to:

1 Like

Shameless self promotion:

Thanks to all testers for finding issues, contributing PRs and making suggestions for improvement!


I didn’t get work yet, but under home settings, I have four Mattermost settings pointing to the Mark I device… is that normal?

Delete Them by pressing the round arows i. The corner. Waite a little while and refresh. Then only the right one rrapears :slight_smile:

1 Like

Since when and on how many devices do you use the skill?

As far as I understand multiple entries appear when you have multiple Mycroft devices which running different versions of a skill.

1 Like

Mmm, I would say I’ve just installed that skill on my Mark I, which is the only device turned on 24/7. My other mycroft instances are currently mostly for development or as a toy on the linux desktops.

Deleting all the mattermost settings on mycroft home has… well, deleted all the settings. I see no mattermost cofiguration at all now.

It should come back by itself eventually but if you reboot the device which resync’s with during boot it should restore the setting block. Assuming the skill is still installed on that device.

I must be an idiot, but I cannot get it work at all.
After rebooting the Mark I, just one Mattermost Chat settings appeared on

I put the username “@malevolent”, my mattermost associated email, and my mattermost password.
I’ve checked both “Enable monitoring” and “Check for update every 10 minutes”. On the advanced settings, the scheme is “https” the URL is “”, and the port number is “443”, the checkbox “Verify SSL certificate” is checked.

It doesn’t work.

Mycroft says “Mycroft Chat monitoring is deactivated” and when I say “Begin monitoring of Mycroft Chat” it says “Mattermost skill not initialised. Check configuration on

Username must exactly match what is shown at > Main menu (hamburger icon) > Account settings > General settings > Username.

Please try “malevolent” without leading “@” for the username.

Now it says twice “Mattermost error: Sorry, we could not find the page” and if I try to start monitoring, it says I need to check the settings.

As it didn’t “found the page”, I tried to put instead with the same result.

PS: I’m rebooting the Mark I after every change to make sure it syncs the changes done on

Adding “https://” to the URL will not work, as there is already the field “scheme” for that - which has the default “https” (please don’t enter “https://” there).

The validation logic for the configuration settings is rather basic so best thing is to leave the Advanced settings on the defaults. But just to make sure - the Mycroft Chat Advanced settings should read:
Scheme: “https”
URL: “”
Port Number: “443”
Verify SSL Certificate: yes/checked

Can you force a reload of skills by sudo service mycroft-skills restart and look at the log entries for Mycroft Chat Skill?

Maybe your Skill installation is somehow broken and a reinstallation by mycroft-msm remove mycroft-chat followed by mycroft-msm install mycroft-chat helps?

I finally got somehow work the skill.
I noticed that after putting my username without the “@”, after saving it put back the @ in front of the username, so I tried to do the mycroft-msm remove mycroft-chat and mycroft-msm install mycroft-chat, but the @ appeared again.
I went to the /opt/mycroft/skills directory and I saw the name was mattermost-for-mycroft-skill.domcross so I think I’d installed the skill on the past from github… I’ve removed the directory manually and reinstalled the skill via msm.
Now I can put the username as expected and logs show no errors of connection anymore :slight_smile:

Anyway, it seems it doesn’t work as well as I would like. Most of times it doesn’t understand me (again, my fault, my pronounced english is even worst as my written english), it’s impossible for me to say correctly “Mycroft”, it always understands or Minecraft or Microsoft… :sob:

So I’d opened the cli and pasted the intents there. The only intent it seems to answer is are there any android messages of mycroft chat. When I tell it to read the all the unread messages or read the messages on specific channel, it answers Sorry, I didn't catch that.