My first try - stuck

On i7 with Lubuntu-18.04, git-2.17.1, python-3.6.8
First of all I tried:
$ sudo snap install mycroft
$ mycroft
So the snap is not the latest and greatest version.

So I downloaded, found I should be on the master branch, and downloaded .
Unzipped it to my home folder .
$ cd ./mycroft-core-master
$ bash

                Welcome to Mycroft!  

This script is designed to make working with Mycroft easy. During this
first run of dev_setup we will ask you a few questions to help setup
your environment.

Do you want to run on ‘master’ or against a dev branch? Unless you are
a developer modifying mycroft-core itself, you should run on the
‘master’ branch. It is updated bi-weekly with a stable release.
Y)es, run on the stable ‘master’ branch
N)o, I want to run unstable branches
Choice [Y/N]: Y - using ‘master’ branch
fatal: not a git repository (or any of the parent directories): .git

Hmmm, can’t find that error message anywhere in .
It looks like it comes from lines 148-9:
git checkout ${branch}

Not so easy - I’m stuck.

Hi Dave, from the messages in chat it sounds like you might have gotten a bit further, but just in case.

It’s best to stick with the exact commands provided for installation:

cd ~/
git clone
cd mycroft-core

The error message you got is because Mycroft-core attempted to use a git command but by downloading the files as a zip you were not cloning the files as a repository. Long story short, try the four commands above :slight_smile:

I would also try the official manual installation of mycroft, it will work and will upgrade without problems. Distribution package systems normally are outdated, and distributions non-official repositories can be problematic, outdated or can arise any undesired problem.

You can take a look to the splendid documentation, where you will find about this topic

OK, it is installed and “running” now and listening on :8181.
I say “hey mycroft” and nothing happens.
I can see in pavucontrol that my microphone is producing a signal.

When I say “hey mycroft” into > Voice typing it produces “ay Minecraft”. How do I tell what is going on if it won’t recognise “hey mycroft” ?

Strange, I’m spanish and it understands perfectly when I say “Hey Mycroft”, and you can bet my spoken english is pretty bad.

Take a look into Audio Troubleshooting - Mycroft AI.

I would suggest doing the basic tests: do a ./ audiotest to see if everything is handled correctly, make sure you have the package pulseadio installed and mic is not muted with the command alsamixer (next image shows is muted when appears the MM and you can toggle the mute/unmute by pressing the “M” key)

And your selected car is “Pulseaudio”

If everything is ok and all the test in audio troubleshooting documentation passes, then open the mycroft cli by executing
./ cli
You should see the audio and mic level at bottom right

If all of this seems to be OK, then perhaps you have some problems with the wake word:

If all the former steps are working… well, try to vocalize a little bit more, as I say, it understands me perfectly, and my spoken English is far from good. Some female users have reported Mycroft doesn’t understand them properly, and that is a known issue because the lack of female models, compared to male voices. This problem will be solved.

1 Like

@malevolent Thanks for your help.
The audiotest works OK, although there is a surprising amount of background sounds of birds in the forest where I live.
Running cli shows mic levels “284 455.5”, whatever that means.
It seems I have 2 input devices - HDMI2 which is muted and my webcam/mic which is not muted.
I wanted to change the wake word earlier but got lost in the instructions. Just got lost again. I can’t find any device settings at
My hotword configuration already has ““module”: “precise”,”
I have vocalised as well as I can, and tried variations, but nothing works.

I am also getting the occasional low-high sound not connected to mycroft activity.

… and NOT getting any sound notifcation when mycroft starts listening.

Sometimes if the mic input level is set quite high, then it has difficulty hearing Hey Mycroft. What is your mic level at in pavucontrol?
Try dropping it to 30-50% and see if that has any positive impact.

If you think pronounciation may be a problem, some of our international community have used Mycroft videos to test this out. Given it is triggering the listener in the video, you can be pretty confident that it should also trigger it on your machine.

Reduced mic volume from 75 to 50, nothing shows with normal talking.
Increasing to 55 and then 60, “Hey Mycroft” caused low-high tones, but no other output. What should it say?
What are the words for the default skills?
Where is all this stuff documented?

The mic level suggestion is the last sub-heading before PulseAudio settings:

It sounds like the audiotest is successful, your CLI is working, and the mic level in the bottom right is jumping around.

So I’m wondering if it’s Precise the wake word engine, or the mic input.
From your terminal can you run:
grep avx /proc/cpuinfo
This should return a bunch of info about the flags supported by your cpu. If you don’t get any response and it just returns you to a blank shell then that will be the problem. We now try to detect this during install so if this is the case we’ll need to look into that more.
If you get a bunch of text back then that’s not the problem and we need to keep looking.

To bypass the wake word and test the mic with the STT service you can you type something like “set a timer”. This will then ask you how long a timer you want, and open an STT stream. If you say something like: “10 minutes” does Mycroft transcribe this into text?

grep avx is positive.
Last para - do you mean start-mycroft cli then type “set a timer”, and say “10 minutes”? Mycroft doesn’t respond. When I type “10 minutes”, it says it doesn’t understand (I think it means the command “10 minutes”).

I meant “:set a timer”

If you type “set a timer”, mycroft should ask out loud “How long of a timer?” and then make the listening sound. Then you can speak “ten minutes”.
This is the output

Yeah, try as malevolent has posted.

The colon is for CLI commands, you can type “:help” to get a list of the available commands
Anything typed without a colon is sent to Mycroft as if you’ve spoken it