Mopidy spotify on Mark1 audio config for built in speaker?

Does anyone have tips on how to get mopidy skill and spotify working with the default speaker output on the Mark 1?

I’ve tried adjusting /etc/mopidy/mopidy.conf as suggested here:

I see mycroft-skills.log recognizing Mopidy Skill:PlayIntent and restoring volume (or handling stop request when hitting the button again) but nothing comes out of the speaker. Using sudo systemctl status mopidy -l I see Logged in to Spotify in offline mode.

With aplay command I need to append -D sysdefault to it for anything to come out of the speaker in the Mark 1.

It should say “Logged in to Spotify in online mode”, mopidy/spotify has recently changed login requirements now one has to create a client id and client secret as well for full functionality (like searching).

I haven’t been able to test the mopidy skill on a Mark 1 (haven’t received mine yet) so if you find some tweaks that’s needed to get it running please report them and I’ll add them to the readme.

The mopidy skill currently only supports album search “Hey Mycroft, search spotify for ALBUM” and your playlists via “hey mycroft play PLAYLIST”

Mopidy on the Mark 1 (using the latest versions of everything, I’ve currently got mycroft-core 0.9.6) requires you to do some minor Pulseaudio jiggery-pokery to get things happy.

# /etc/mopidy/mopidy.conf
# ... insert the rest of your configuration here ...

output = pulsesink server=
# /etc/pulse/

# Uncomment this line in the network access section, and add the auth-ip-acl parameter.
load-module module-native-protocol-tcp auth-ip-acl=

Make both those configuration changes, reboot your Mark 1 (it’s a bit of a pain to reload Pulseaudio for the mycroft user otherwise), and Mopidy will use the exact same output as Mycroft’s speech.