Mimic3 Voice download error

So i followed the instructions and installed mimic3 on my raspberry pi 4 running ubuntu mate. And it works fine, but only for one voice: en_UK/apope_low. Whenever I try to chose a different model i get an error:

URLError: <urlopen error [Errno 99] Cannot assign requested address>

i tried installing all the different ways, tried downloading the voices manually using

mimic3-download ‘en_US/*’

but same error. I think en_UK is downloaded as default. I tried cloning the voices repo from git 'https://github.com/MycroftAI/mimic3-voices' and copying them to the voices directory. But then I get parsing error. Anyone know how to help me get other voices?

I have the same error when cloning the repo. You need to install git-lfs first so you can download the big files, usually generator.onnx ones

I have no problem cloning the repo. But after cloning it, I cant use it.

I get the error:

urllib.error.URLError: <urlopen error [Errno 111] Connection refused>

when trying to run mimic3 with any voice other than the default and also while trying to download the voices maually using the command:

mimic3-download ‘en_US/*’

If you cloned the entire repository using a web browser, it does not download the actual generator.onnx files (Instead only a reference to it is included, which has the same file name.) The actual file should be a few dozen Megabytes. The file downloaded when cloning the repository via a browser is only about 133 bytes.

If this is indeed the case, you can do any of the following:

  1. If you need only a couple of voice models, you can navigate to the required voice’s folder in a web browser and download the file for the voice model you need individually. Then replace the generator.onnx file in the repo you downloaded earlier with this new file.

(This is impractical if you require multiple voice models. See the next point for a less tedious solution.)

  1. As @atd mentioned, this happens because some larger files are stored with git-lfs, and you need to install it. Use:
    sudo apt install git git-lfs
    Then run the following command to clone the repository:
    git clone https://github.com/MycroftAI/mimic3-voices
1 Like