Mimic recording in azure k8s

Hello together,

tried to run mimic recording in azure k8s cluster. It does not work, even tell me that “Your browser doesn’t support native microphone recording. For best results, we recommend using Google Chrome or Mozilla Firefox to use this site.” That is strange, because I use Mozilla Firefox :smile:. I tried the spin up with docker-compose, this works perfectly (in the same browser). The service in azure k8s is HTTP, so no certs. is that the issue, somehow?

Best Regards

While downstream projects have taken over or replaced most of Mycroft, for a variety of reasons, none of us have adopted Mimic. A number of other open source STT and TTS systems are supported by the surviving descendants via a plugin system.

For more information, see the pin, and please don’t hesitate to follow up.

ninja edit: one of those alternative systems supports all the same voices, iirc

GitHub - rhasspy/piper: A fast, local neural text to speech system can be regarded as successor to Mimic.
It is from the same developer that worked on Mimic3 for mycroft.ai


Indeed, I left it out lest it should come across like politics, but the biggest reasons OVOS declined to adopt Mimic were the fact that Piper exists, and that Piper is more compatible with our licensing practices. It’s a great engine, and we wholeheartedly endorse it.

It can most easily be added to the OVOS Assistant or a Neon instance using the plugin system. I’m writing this from an electrified potato, so it’s hard to check, but I believe it’s ovos-tts-plugin-piper

1 Like