Microphone worked one day stopped working the next


Yesterday I got my speaker and microphone set up for my picroft (raspberry pi 3 model B).
Everything was working as a charm.

I used this guide to get it set up:

After setting it up I added the posibility to use the pi as an IR remote.
To do this I installes lirc on the pycroft and added some config files for lirc.
I also imported this skill: https://github.com/ChristopherRogers1991/mycroft-irsend/
Looking trough the code for this skill I dont think this would mess with my audio settings
Otherwise I made no changes. I tested the new IR features trough the text interface.

Today I wanted to see the IR module work witch speach and fond out my audio no longer works correctly.

The .asoundrc and /etc/asound.conf file are still the same.
aplay and arecord work when adding the option -D plughw:1,0.
This -D option was not needed yesterday and if i understand correctly the point of the .asoundrc file is to set the default defice for aplay and arecord

In the mycroft.conf file I put the
“play_wav_cmdline”: “aplay -D plughw:Device,0 %1” (Device being the name of card 1)

The sound from mycroft is thus still working as it is configured to use the correct device.
I dont see a setting for arecord in the mycroft.conf and thus i think its using the default one which still worked yesterday but now needs to be specified.

I did check the alsamixer volumes and put all of these to the maximum so this should not be the problem

I see 2 solutions to my problem:

  1. find a setting in mycroft.conf to set the device to be used by arecord
  2. make it so aplay and arecord use the correct default device

For both I seem to be at a loss now.

Hope this is enough information for someone to diagnose the problem.

For anyone faceing a similar issue I found this:

I’m not sure why I had pulseaudio and if this is in the core mycroft code or if it was installed as a requirement for one of the other skills/packages i used. I took the fast way of uninstalling pulseaudio instead of properly fixing it but this solved the issue of aplay not using my /etc/asound.conf file.

If this is needed for something in mycroft i will reinstall it and fix it properly.
I will be posting a better solution here if i get to it :slight_smile:

the pulseaudio package seems to have been a depricated dependency of lirc. Running the suggested sudo apt remove hopefully completely fixes the issue

How did you go with with @PauloVH - is your microphone working OK now?