Microphone stop working on picroft

Hello guys,

I have a problem with my picroft installation, after update to the newer version picroft stop listening the wake word and the mic level stay stuck in —7.86 without any change. I am using ps3 eye as microphone.

Do you have any ideas about why stop working?

Thanks for reporting this, @Dimitris_Soutas.
We’ve had several reports of this issue with Picroft on version 18.02.

Can I please confirm the following information:

  • Picroft on RPi3
  • Version 18.02
  • Microphone: PS Eye 3
  • Boots OK
  • Pairs OK
  • Listens to Wake Word
  • Does not respond to commands

Hi @KathyReid following you will find my input.

I also getting this error messages from mycroft.

21:07:00.483 - SKILLS - DEBUG - {“type”: “1017122086:TimeSkillupdate_display”, “data”: {}, “context”: null}
21:07:10.501 - SKILLS - DEBUG - {“type”: “1017122086:TimeSkillupdate_display”, “data”: {}, “context”: null}
21:07:16.508 - mycroft.skills.settings:_poll_skill_settings:401 - ERROR - HTTPSConnectionPool(host=‘api.mycroft.ai’, port=443): Read timed out. (read timeout=15)
21:07:16.512 - mycroft.skills.settings:_poll_skill_settings:402 - ERROR -
Traceback (most recent call last):
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/skills/settings.py”, line 398, in _poll_skill_settings
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/skills/settings.py”, line 372, in update_remote
skills_settings = self._request_my_settings(hashed_meta)
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/skills/settings.py”, line 440, in _request_my_settings
settings = self._request_settings()
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/skills/settings.py”, line 456, in _request_settings
"path": self._api_path
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/api/init.py”, line 53, in request
return self.send(params)
File “/usr/local/lib/python2.7/site-packages/mycroft_core-18.2.0-py2.7.egg/mycroft/api/init.py”, line 78, in send
data=data, json=json, timeout=(3.05, 15))
File “/usr/local/lib/python2.7/site-packages/requests/api.py”, line 56, in request
return session.request(method=method, url=url, **kwargs)
File “/usr/local/lib/python2.7/site-packages/requests/sessions.py”, line 488, in request
resp = self.send(prep, **send_kwargs)
File “/usr/local/lib/python2.7/site-packages/requests/sessions.py”, line 609, in send
r = adapter.send(request, **kwargs)
File “/usr/local/lib/python2.7/site-packages/requests/adapters.py”, line 499, in send
raise ReadTimeout(e, request=request)
ReadTimeout: HTTPSConnectionPool(host=‘api.mycroft.ai’, port=443): Read timed out. (read timeout=15)
21:07:18.265 - mycroft.skills.settings:_request_my_settings:439 - DEBUG - getting skill settings from server for TimeSkill
21:07:18.274 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1):

OK, so those error messages are not related to microphone configuration. They are related to Mycroft trying to synchronize settings with the server - home.mycroft.ai - which occasionally times out.

I reinstall picroft on my rpi3 but I have the same error messages… any ideas?

Exact issue here. Was working fine. Rebooted and now stuck at 7.86. Did you find a resolution?


I have just rebooted mine , with the Pi3 and the PlayStation mic and now it has stopped listening to the mic…
I have rebooted a few times hoping it would come good, but …nope… no audio level showing at all :frowning:

I think I will give this up as a bad joke & go back to the Linux VM…

Did you guys used raspi-config to force all audio through analog speakers?

Seen similar issues, with that 7.86 number when I was screwing around with multiple sound-pulseaudio configurations. I believe, that force audio thing made the difference…

I have no problem with the audio OUT… That is working no problem , I can type a question and get an answer, but the USB mic has failed and attempting to change the device seems to make no difference…

I know! Had the same. For some reason forcing the output also fixed my microphone :wink:

Anyhow, know a way how to fix it as I said in another topic, but need to convert my crappy notes to something usefull…

I am backing up that sd card and about to start again with a fresh image - I really want to see why it stopped though

So I completely restarted with a fresh image from the website and now the PS3 Mic STILL won’t work… It worked perfectly for 2 days .
Brilliant… I only bought the thing so I could use it with picroft! (and i got a new Pi for Fathers Day to set up!)
What goes on here @KathyReid ?

OK so that is WEIRD… I shut down the Pi, plugged the PS3 Mic into my Win10 PC and let it do it’s installing drivers thing, then plugged it back into the Pi and started it again and now it works again…

maybe there is some state or device id that is stored in the mic device that picroft “broke” ??

Hmmm interesting.

My guess here is that PulseAudio hit some sort of SUSPEND state. I’ve seen a lot of PulseAudio talk a lot about setting the status of sources to SUSPEND but I don’t know how to solve it.

well, I have a working clean install right now :slight_smile:

1 Like

This post resolved it for me. I’m not sure if this gets changed via an update or something, but here’s what my resolution was.

Link: USB Mic Won't Work (Used To) - #2 by J_Montgomery_Mycroft

Here’s what I did and it resolved it. I uncommented the load-module lines, rebooted, and all was well.

sudo vi /etc/pulse/default.pa
uncomment and change:
load-module module-alsa-sink device=“hw:0”
load-module module-alsa-source device=“hw:0,0”

Hope that helps.

1 Like

thanks Sean… My USB mic has stopped working ( AGAIN) and I tried your edit to the default.pa file, (I actually simply added those two lines) , but it made no difference…

Just a stupid thing to test, but perhaps it works for you as well;

  • stop Mycroft
  • delete: /var/tmp/mycroft/web_config_cache.json
  • start Mycroft

I had this issue and editing default.pa worked. You have to know what your USB microphone address or name really is. (It may not be “hw:0,0”). I actually used the device name, which is problematic, because if I ever change the microphone device, I will have to remember to change it.

My method was similar to the top of this page: