Mark II - unable to pair device

Hello. I recently assembled a Mark II dev kit. It is connected to my wifi network.

Now I’m at the step where the Mark II screen shows a 6-digit code and “pair at”. After logging into my Mycroft account and adding a device, I enter the 6-digit pairing code. On my Mycroft account page it says “Your device is ready! Here are some sample questions and commands…” After I click on “Finish”, it says that my device is “Connected”. However, Mark II voice assistant keeps telling me that I have to register my device with the code … After about a minute, on my Mycroft account page, the status of my device is “Disconnected.” I’ve repeated this process a few times (I get a new 6-digit pairing code each time) with the same outcome. Any suggestions to help are appreciated.

Hey Kelly,

There was a bug in the Pairing Skill and we just found that the fix wasn’t getting loaded on the fresh images. If you restart your device and pair it should connect properly. If not please let us know and we’ll dig into it further.


I tried a restart a few times and unfortunately, my device is still not able to pair.

Let me know if there is something else I should try.

Hmm there seems to be a different issue that’s popped up - investigating it now.

Hi Kelly, this has been resolved.

There was a bug introduced into one of the Pantacor API endpoints that failed to report the update channel for the device. This data is expected during pairing so was failing.

We’ve fixed the immediate problem and looking at ways to improve our error reporting so we catch any future regressions more quickly.

Let me know if you have any more trouble getting your device setup.

Thanks Gez, my device is able to pair now.

1 Like