Mark II DevKit will not boot anymore

When I assembled my Mark II DevKit last year following the instructibles webpage, it worked great. But I had to unplug it and find a place for it and got distracted and let it sit on a shelf.

Recently, I needed to test something on a Raspberry Pi, and I didn’t have one handy, so I pulled the one from the DevKit. I neglected to save the mycroft build that was on the tiny flash drive, thinking I could just download it again.

That little experiment over, I put the Raspberry Pi back into the devkit. I downloaded the latest stable production software build. It will not boot. Nothing shows up on the screen.

The only thing that kind of works is the sandbox Dinkum image called “20221108-mark2_dinkum.img.gz” but it does not recognize the built in microphone, and so far I can’t seem to create an SSH user with the Raspberry Pi Imager.

Is there any chance I can have access to the software image that was available back in April or May of 2021? I think I’d like to test that, and then see if I can upgrade from there.

I’ve managed to re-image the 20221108 mark2 dinkum image, and I was able to set up an ssh user. When I booted for the first time, all the processes on the screen said [OK] in green letters except [FAILED] failed to start New User Configuration Dialog. Mycroft finished booting, and he spoke to me and said I should connect the device to my account, which I did, and then he said I could ask some questions. But he didn’t hear me because the mic is not recognized as it was back when I first built the devkit.

I connected via ssh and ran ‘sudo apt-get update’ and ‘sudo apt-get upgrade’ and rebooted, thinking that might help it recognize the microphone. But no love.

I’ve attached a photo of my Mark II DevKit with the screen showing there is no microphone.

Any ideas?

Try sliding the rightmost button on top of the enclosure.

Hope this helps.

-Mike Mac
1 Like

I will give it a shot when i get home friday. I don’t remember seeing buttons on the enclosure. But i will see when i get home.


I’m home. The rightmost button is volume. As is the middle button. There is a button in the middle of the circle of LEDs, but I’ve no idea what it does. Apparently it does nothing.

There is the left most thing. I had no idea it was a slider. I slide it to the left and nothing happens. Slide it to the right and the border around the screen turns from red to blue, the LEDs become unlit, and the strike-thru image of a microphone disappears.

Yet when I say, “Hey, Mycroft,” nothing happens. Nothing. So I’m at a loss. I know it worked with the software from last year. Any leads on how I can get a copy of that?

That switch is on/off for the mic. When the red ring is lit, mic is off. Try turning the mic on and rebooting