Mark I - white eyes, boot doesn't finish, 'Reset' doesn't work

This just started 1 week ago. I have had issues updating in the past where she would get ‘stuck’, but I don’t see anything about an update being released.

She boots, if I pull the power, through yellow eyes to white and then doesn’t go any further. ‘Restart’ will reboot her, but she goes back to the same spot. ‘Reset’ prompted for ‘Wipe’ and ‘No’, but selecting ‘Wipe’ didn’t seem to do anything.

Getting ready to pull her apart and do a manual SD card restore. Anyone. else having any issues.

Hey, that does sound like a weird one.

The other thing you can do is reinstall Mycroft by switching to the dev channel and back:

sudo mycroft-use unstable
sudo mycroft-use stable

These take time, but it is slightly easier than reflashing the sd card sometimes.


Thanks for the tips. This worked to get her back to the blue eyes and working.

1 Like

Yay, good to hear. I’ve added this to the Mark 1 troubleshooting docs

1 Like

One other note here.

Getting her back to the Google voice and she is having issues. Changed her to ‘American Male’ without an issue. Changed her to ‘Google Voice’ and she is stuck on the yellow eyes.

I’m having the same issue, except after flashing a Mark I image to an SD card. When I plug it into a monitor, I see that a kernel panic occurs while booting up, so I can’t even get to a point where I can switch to the dev channel.

I tried this image, which appears to be from March 2020. Is there a newer image I can try, or a checksum for this one so I can make sure the image is not corrupted?

The Mark I does seem to be having a hard time with updates. Mine is back to normal (other than a weather issue). I used the download from Google Drive - Virus scan warning which is the latest official image. Once downloaded, flashed and the Mark I was put back together, it took a couple of days for the eyes (process during boot) to settle down and work.

NOTE - switching to the Dev channel and back worked for one issue, but didn’t solve the Google voice one. I ended up flashing an SD card as noted above to resolve all issue.

Thanks, I’ll give that image a try. It appears to be older than the one I used, but I could have been on an unstable image. I’ll be more patient with letting it boot up.